Sketchup 2017 Installation fails Win8.1 [could not open key - SOLVED]

Hello,

When I install Sketchup 2017 it gives the following error:

Could not open key:
HKEY_CURRENT_USER\Software\Microsoft\Internet
Exprlorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION

I tried the following already:

  • I already checked in regedit.exe and made sure I got all the permissions.

  • I also did reset my IE settings.

Edit:

  • Also right-clicked “Run as Administrator” on the .exe file

Sketchup error

I also ckeched this thread, a similar problem with Sketchup Make

When you started the installer, did you right click on tit and choose Run as administrator? Or did you just double click on it?

Yes, I did right-click and chose “Run as Administrator”. Did not solve the problem unfortunately.

Try updating Internet Explorer
and empty all the cache:
https://forums.sketchup.com/t/did-you-know-that-clearing-the-cache-and-cookies-in-your-internet-browser-is-still-a-great-way-to-solve-problems-connecting-sketchups-web-properties/123?u=mikewayzovski
reboot
reinstall

If the problem is still there after what @MikeWayzovski suggested, you can try running regedit.
Windows Key + R and then type regedit
You can use the folders to access to:
HKEY_CURRENT_USER > Software > Microsoft > Internet Explorer > Main > FeatureControl > FEATURE_BROWSER_EMULATION
As far as I can see, SketchUP needs to modify the value of path creating a new key, you need administrator rights, make sure not other programs like some antivirus or similar has enable any feature to block modifications on the register, if it’s the case try turning it off during the installation process.

Thanks for reacting. I tried your suggestion. But that did not work.
I did however solve the problem by resetting my complete PC. I know it is not a recommended solution but I had to do it anyways. I now have Windows 10 and it works fine.

Thanks for helping

I did not check you suggestion if maybe some antivirus program is blocking it.
I did however solve the problem by resetting my PC, which I had to do anyway. See other comment. Thanks for helping.

How can I close the topic?

It looked like some issue during the installation process, if you fixed it with reboot then it’s ok, There is nothing on that, you only do install process once so … I don’t see any problem.

There is no way to close a topic (as far as I know, I think they will get automaticaly closed after 3 months from last reply), but you can check as solution the post you think it can give a tip or workaround about how to fix it.

If I were you, I’d check your own post in which you tell us you fixed it reboot.

Thanks for responding. I did check it. (New to the forum so… xD)

1 Like

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.