Windows 8.1 Install Issue


#1

Hi

Sketchup on startup advised there was a new version, which I downloaded and ran the installer. Towards the end of the installation I got the following error message:
Cannot open Key
HKEY_Current_User32\software\microsoft\internet explorer\Main\FeatureControl_Feature_Browser_Emulation

When I clicked ok the installer promptly backed itself out and removed itself and the current version I was running.

On my PC there is no HKEY_Current_User32 folder in the root of the registry, and I cannot add a new Key.

Has anyone else experienced this issue ? or know how to solve it? I have tried Googling this but to no avail.

Thanks

Mark


#2

Is IE up-to-date, cache and temp files cleared? SU, like other programs that interact with the web, use the default OS browser even if you prefer to browse the internet with another browser.

Go to the MS update site and get latest system updates for IE. Some other IE maintenance to look into.

@jody, have you seen this before?


#3

Someone using Win 7 discovered a recent MS OS update caused a problem Installation attemopt returns object already exists error. This may affect Win 8…


#4

I have not seen this before but your research @catamountain makes sense. I’ll escalate to the QA team to see if they can test our installer. A couple of questions for you @mark_phillips1965:

  • What version of MS Windows do you have installed?
  • Are your System Updates current?
  • Have you done any updates recently or made other software changes?
  • What version of MSIE do you have installed?

I haven’t seen this from other users but if it’s a new update from Microsoft then it could start popping up all over the place.


#5

Hi
Sorry for the time taken to come back to you with answers to your questions:

I have Windows 8.1 installed 64 bit pro edition it is set to auto update on all patches etc so should be up to date

I have not done any recent changes, but clearly patches etc auto installing will change things regularly.

IE is version 11.0.9600.17239


#6

Ok so finally I have solved the problem. Essentially I needed to delete the offending Key “Feature_Browser_Emulation” from the registry.

Unfortunately as I did not have permissions to do this even though I am an administrator I had to carry out the following steps:

  1. Download psexec.exe from Microsoft which is available here: http://technet.microsoft.com/en-us/sysinternals/bb897553.aspx

  2. Open up the command prompt as an administrator i.e. right click on the Windows 8.1 start icon, and select Command Prompt (Admin)

  3. change folder to the location where psExec is located and use the following command:
    psexec.exe -i -d -s c:\windows\regedit.exe

  4. Regedit should now open

  5. locate the offending key this may not be easy to find as Regedit is now running in Admin mode therefore the current user is now admin, which means Hkey_Current_User now refers to Admin. To find the key for the regular user look in Hkey_Users. On my machine the keys under here referring to the user are encrypted, however the content is not. I searched each one in turn until I located the one with the Key I was looking for:
    HKEY_Current_User32\software\microsoft\internet explorer\Main\FeatureControl\Feature_Browser_Emulation which on my machine corresponded to only one entry.

  6. delete the key Feature_Browser_Emulation

  7. Run the Sketchup install and all should be good.


#7

Hi Mark,
I’ve the same problem in installing the sketchup in windows 8.1, the registration key authorization issue. I opened the regedit with your advice by executing psecexe.exe.it did work to get onto the main/ key but cannot show off the featurecontrol key. So can’t delete the key. When re-entry the regedit directly without executing psexec.exe , it shows the key feature control , but can’t remove, edit the key as i haven’t the right to do it.

What’s wrong? Pls help.

Alfred