New version of 2017 make - slow response time for object selection

2017
sketchup

#1

running new version of 2017 make - just updated it today and it runs too slow on my windows 10 pc. my system meets all of the system requirements, checked video drivers for my intel HD graphics4000 card - no updates needed.

so I am uninstalling the 2017 version and rolling back to version 2016 until you guys can fix these issues.


#2

so I rolled back to 2016, and of course now I cannot open any of my models that I created in the original verion of sketchup 2017 ,… So is there a place where I can download the orginal version of sketckup 2017?


#3

How did you check your graphics card’s driver? Was is it via Windows Update or did you check Intel’s site?


#4

I used the Lenovo update checker. I also ran the systems check from sketchup which gave me all oks…including the driver…


#5

Could you post the driver version?


#6

This isn’t a Help Center problem, moving it… please be sure to select the appropriate category when posting new topics.


#7

10.18.10.4358
Intel HD graphics 4000 in a Lenovo laptop ideapad P400


#8

There have been a number of other users who reported the same problem. In every case the fix was to uninstall an automatically installed Windows security update. After it was removed, the problem was resolved.

Shifting back to SU2016 is not really the answer to the problem.

As for converting your SU2017 files, you can back save them as 2016 files by using File>Save as… in SU2017.


#9

Ok well that doesn’t sound like a very good option… windows security updates are published to close vulnerabilities in the OS. without them, that leaves my system open to that vulnerability.


#11

I would try installing the latest driver downloaded directly from Intel.


#12

can you provide more specifics about the specific windows security patch? if it is not a critical vulnerability then I might be more apt to consider it.


#13

It’s easily searchable here on the forum.

You should also make sure the graphics drivers are up to date per @mchandler.


Toolbar malfunction
#14

thanks for this link… I used the latest version directly from the Intel site and that resolved my issue.

I was able to reinstall the 2017 version and it now responds just like the previous version did.

thanks for your help…


#15

Glad to hear that it fixed the problem.


#16

Is everything still working correctly? We’ve had some reports of Windows installing an update that causes the issue to reappear.


#17

yes I am still working fine… I don’t think my windows update occurred recentlyt though… its only been about a week since the last round of updated from Microsoft.

thanks for the followup…


#18

2 posts were split to a new topic: Problems with Intel HD 4600 GPU


#19

This topic was automatically closed after 90 days. New replies are no longer allowed.