New Motherboard, SketchUp won't work


#1

Had to have my motherboard replaced, now I get “trouble with your license” message.
I tried deleting and re-installing Sketchup, but it keeps giving me the same message because it recognizes my computer.

Should I “Remove License”?

Drew


#2

you’d probably have to remove and reapply the license, try to have SketchUp remove the previous licence activation from your account / licence with them


#3

You probably replaced just the MB while keeping the same disk and same user data? If so, yes you need to remove and then reapply your license because the data on the disk ties SketchUp’s license to the prior MB and so to SketchUp it looks like you cloned your software onto an unlicensed computer.


#4

the sketchup license is tied to the MAC address of the used Network Interface Controller (aka network adapter) during license activation. New motherboard = new NIC = license activation gone.

An active product activation can and should be removed at “Help > License…” (Win) resp. “SketchUp > License…” (Mac) before dropping a system/motherboard.


#5

Thanks, your idea worked!!!


#6

Think I spoke too soon.

My Sketchup is now “not responding” to any of my older files done on the previous computer.


#7

Please clarify what you mean by “not responding”. Unlike the app itself, SketchUp files are not tied to a license or to hardware, so this isn’t a result of the new motherboard.


#8

It took awhile but the my Sketchup took awhile to wake up. It was running very slow and unresponsive.
After 30 minutes, it started to pick up speed. Very strange, but all seems to be working now.

Thanks,


#9

If the new MB has integrated graphics (likely) and you also have a separate graphics card, be sure to check that SketchUp is using the separate card.


#10

I would, but don’t know how…


#11

right-click on desktop and look for something like as e.g. “NVIDIA Control Panel”, go to the 3D settings and configure the dedicated (high performance) graphics card to be used by Sketchup:


.
.
The “Graphics Card: 16ram” provided in your profile is surely not correct, check “Win+R > dxdiag > Display” for correct information.