New floor plan but dimensions need adjusting

dimensions

#1

Hi All,
I am getting through a new floor plan at the moment but I am having problems with the measurements. Basically, when I type in the measurements box my preferred measurements for the two sides of the house, the top and bottom of the floor plan then readjust themselves. I then go to adjust the top and bottom but then the sides go back to the old measurements. I have tried to use scale and resize the entire floor plan however I have found this doesn’t fix the problem. Basically, I need the sides and the top and bottom of the floor plan to have my specific measurements as per my assignment.
Any advice would be great - I am self teaching.
Thank you, Danielle.


#2

How to do this depends on how your floor plan is created. Is it a group or component or just basic geometry? is it a dynamic component? (I can’t imagine though), etc.
The best thing you can do is to share the floor plan file so one can see what you are trying to do.
Also, you never click/type into the measurements field. It may be open (at certain times during an operation) to accept input. At that time you just type the value(s) and hit [Enter].

I think you need to apply the ‘Move’ tool on certain selections of your floor plan to adjust it to the sizes you want it to be. But we need to see the plan.


#3

Hey, thanks for your reply. I will try the ‘Move’ tool actually. This is something I didn’t think to use. I will see if that makes a difference and on certain ‘sections’. Not sure how to do it but I will work it out.
Basically, I had a template of a floor plan I had to import so I traced it and then deleted the original behind it. I only learnt yesterday how to use the tape measure and check my own measurements against the assignment floor plan so it’s all new for me.
Maybe I should have learnt this part earlier to save the hassle of this problem.


#4

If you used the Tape tool you may have used the very useful , resize the model option. If you had used the scale tool instead you whold have scale one dimension rather than the entire model.
Best to show us what you have and what you want, otherwise we are guessing.


#5

You can’t learn all there is at once to know how an application works. Hard to tell if learning things in a different order would have helped.
Just ask away and preferably with some screenshots or the file itself.


#6

Thank you! I will try and copy and paste the floor plan (or somehow into this) so everyone can have a look.


#7

When replying or adding a new post to the forum you can upload your file or an image with the seventh icon from the left (Upload) above your text.
image


#8

Oh thanks that helps heaps!!! Will do


#9

Not knowing your specific case, here in general is the difference between using Scale and Move for making changes in the size of things at a glance:


Notice that scale distorts all the parts inside the whole, which you often don’t want.


#10

Thank you ! I will definitely try this too !!! Sorry will upload my floor plan soon.


#11

Hello @Danii82,

Welcome to the SketchUp Community Forum. Please read the Private Message that was sent to you.


#12

Hi All, please see a snippet of my floor plan. The sides are the correct measurements however the top and bottom should be 9600mm however it reverts back to the 9569mm when I adjust the sides. Quite frustrating. Hope this helps a bit ?

Thank you !!!


#13

You could try this:
Select the outer rectangle of the plan
S for Scale tool
Choose the scale tool handle to scale along
Red axis
Type the dimension you want it to be 9600mm
(remember to type the units - mm in this case)

Repeat for the inner side of the outer wall, or delete it and use Offset from the outer perimeter.

If that doesn’t work, upload your model here (If it’s less than 3Mb, or to 3D warehouse or a file sharing service like Dropbox and post a link here.)


#14

Thank you John I will give this a try. Maybe my entire floor plan is off hence why it can’t stick to the measurements I add in.


#15

Did you use the Rectangle tool or the Line tool to draw the perimeter?


#16

Hi, I used the rectangle tool. I think I deleted too many lines when I traced initially the floor plan hence I had to redo the rectangle again which is why it doesn’t look even . I don’t really want to start all over again.


#17

Alternatively, just redraw the Rectangle and type in the measurements


#18

Rectangle tool or line tool, it doesn’t matter. Once the rectangle is made, for SketchUp they are just four edges and a face.
In ‘Model Info’ > Units > disable length snapping.
Select both edges that represent the lower wall in your image. Move them down some arbitrary distance and let go of the mouse. Immadiately type 500mm and hit [Enter] to make the length 9100 into 9600.


#19

Hi. thank you, what does disabling the length snapping do ?""? I haven’t heard of this as yet.

Thank you.


#20

Hi All, Just an update. I have actually started my floor plan again but it has solved the dimension problem. I found that nothing else was working so maybe it was because the entire floor plan wasn’t correct to begin with.
I may start a new topic regarding how to add the windows and doors to the floor plan.
Thank you.