How can I make large floors 100" on the plane?

sketchup
advice
projecttoplane

#1

Riverarch - 1 floor ver. 2.skp (1.5 MB)
I tried several times to get a perfectly flat floor that happens to measure about 250’ X 800’ but everytime I do it, it winds up being off by a pixel or so onscreen, which translates, in the most recent case, to 3/16" of an inch when I create a wall 800’ on the edge (and fractures other walls at right angles too, or the floor). Worse, I don’t even see this until I zoom way in, or even when I save. For some reason SU doesn’t show the distortion until I save sometimes.
Is there a way to get a floor perfectly planer other than by drawing it? Maybe a set of dimension I can enter. Or maybe some way to tell SU "Hey, make this plane perfectly flat!"
Can anyone create the floor in the dimensions shown? I can add the other objects later.


#2

I looked at your file and the floor rectangle may be flat / planar, but compared to Z=0 it isn’t all on ground plane.

I have no trouble starting with a rectangle 250’ by 800’. drawn on the ground plane.
With the rectangle tool I drew a rectangle, arbitrary size and then typed 3000,9600 and hit [Enter].
The input values (here inches input without units) is due your template set to inches.
I could have typed 250’,800’ [Enter], getting the same planar result on ground plane.

Sorry, I don’t see the problem you are having.


#3

What happens if you use the Rectangle tool, start it with one corner at the origin, drag it out a bit, then just type 250’,800’ for its measurements.


#4

The problem is I have cutouts on two corners…but I suppose it would be easier to just cut them out later?


#5

Is this close enough? I just drew a rectangle on the ground plane starting at the origin. No special tricks.


#6

Cutting out corners later doesn’t realy matter but may be more convenient in work flow.

Note that you do not have to start at the origin. I drew the rectangle at some distance next to your geometry.


#7

That would be a safer way to assure that everything is planar. Depending on the shape of the cutouts it might also require fewer operations than drawing edges one by one!


#8

What everyone else has said!

Plus, I’ve got this sneaking suspicion that you’re intentionally avoiding inferences! Why?

  • The wall that is constructed with one corner near - but not on the origin. It’s only off by 1/16" in the red direction.
  • Your floor is placed very close to (but NOT at the same Z location) the bottom of the walls (in the Z, or Blue direction).

Why do I think this is intentional? Because you haven’t isolated the wall in it’s own grouping (group or component), so when you try to draw other things near it, as you get close, SketchUp will “snap” to a point it infers you want to use. But that’s a problem with loose geometry! When you finish the new geometry, it MERGES with the wall. Since you don’t want these things to merge, you zoom in really close, so you can place them near each other without merging.

There is a very basic workflow:

  1. Draw a logical piece of your model.
  2. Select all parts of it
  3. Put it all in a group or component

By doing this, you avoid accidental merging of geometry - and you no longer have to move/create something “close, but not touching” to avoid merging.


#9

Turn OFF Length Snapping


Learn to model precisely using keyboard entry via the Measurements box.


Upon opening the model you shared I found the Camera FOV set at 7.54 deg.
Such a narrow FOV approaches the visual distortion created by setting the camera to Parallel Projection mode.
Set the FOV back to the default 35° for a more comprehensible view while modeling.