New, Evaluating Sketchup Pro, Bug with Circle Tool Selection, Stability?

bug

#1

Greetings,

I’ve been evaluating Sketchup Up Pro 2018 for the past two weeks. I’m learning and making progress but I have two issues so far. The second is the one of most concern.

  1. There appears to be an occasional issue with the circle tool.
  2. I’m experiencing stability issues.

I am putting a 5/16" hole in a component. Using the push tool, I “drill” from the surface of the circle drawn on the front face of the component through to the back which I locate using an inference. The hole and circle have had to be deleted multiple times as I learn to get the desired result. After about 30 minutes of this, the circle tool changed to the polygon tool and would not change back. I tried:

  • Selecting with keyboard “c”
  • Selecting using the tool bar
  • Close the component
  • Repeat the above
  • Exit Sketchup and try again

The last action cleared the decks and I was able to select the circle tool again.

Separately I have had at least 4 crashes that force closed since the evaluation began. Only one produced a crash report screen. In one instance I lost work. Do others have similar reports of stability issues? Perhaps it is just my environment.

Thank you,
Kenton


#2

It might be that the circle tool had too few edges and made it look like a polygon ( essentially the circle tool is a polygon tool with many sides) when you invoke the circle tool you can type a number which will give you the side count…if you want a really smooth circle make this 30 to 70? depending on task. try to drag it out on an axis.


#3

I’d suspect your crashes are being caused by your graphic card setup. The Intel cards are not generally very compatible with SU and the Display link adapter can cause problems. Check for the latest drivers for the Intel.
Also, when installing it Sketchup, and many other programs, need to be installed by Right clicking on the install.exe and choose Run as administrator. (this is basically due to changes in the permission setup of windows itself.) If you didn’t install this way, or don’t remember, you can do it now and choose Repair when it gives you that option.

5/16 is small hole and as such you may be running into issues of tiny edges, If you have used the default 24 for the circle then the segments of that circle are approx 5/64ths. When you get down to these sizes problems can occur. Adding even more segments to such a small circle will be even more of a problem.

How do you know it has switched to the polygon tool, what is telling you that? Are you seeing fewer segments or are you seeing hard lines on the faces, therefore seeing the facets that make up any cylinder.

It would help to see the model or images.


#4

Should one mention the Dave Method at this point?


#5

Thank you for your help WRBC.

To clarify, the issue was with selecting the tool, not drawing with it. The mouse cursor displayed as a hexagon for the polygon tool. If I tried to select the circle tool it didn’t “take;” the polygon tool remained selected.

Thank you for the information on the circle segments. The default was not an issue in this case so I’ll file this away for future reference.

Regards,
Kenton


#6

Box, thank you for your reply and tips.

It would make sense that the crashes are perhaps lower-level, driver related as there is no exception caught. My setup is very business software and coding oriented. Until this exercise with Sketchup, my work has included lightweight presentation graphics and has never needed much horsepower in that department. I do realize that USB graphics cards are a bit sketchy (probably the wrong word for this) yet till now have been adequate for my use. This is a dual monitor setup running an external Displaylink device. The on-board Intel card is on the laptop. Sketchup is on the external monitors with the tools un-docked on one side. For the most part things are working fine.

One observation that requires more data is that Sketchup may not like being undocked, coming back from laptop sleep or some combination. In that case, easy remedy is not to be lazy and just shut it down each time.
At any rate, it is only while I’m busy using it that it has force closed, so that argues against it.

  • Latest video drivers are installed
  • Sketchup was installed as administrator

Regarding segments, the setting to change number of segments was not modified. As I clarify for whiterabbit above, it was with selecting the tool, not the drawing of it that was the issue.

I know the tool was stuck in hexagon mode as indicated by a hexagon for the mouse cursor. I could not “unstick” it - the circle tool could not be selected. I wondered if it was just a cursor display issue, but when I drew with it, it did draw the a hexagon. After restarting I was able to “drill” my holes, properly aligned through multiple components (one at a time - using the push tool and solid tool subtraction).

At any rate, none of this amounts to enough to scare me off at the current rate the issues are occurring, Autosave has recovered all except one crash. (PowerPoint will bomb-out on me on me too and maybe that is also another data point about trying to push the USB setup).
Perusing the forum, I don’t see major complaints about the quality of what is very complicated software - that perhaps is my primary question.

I’m enjoying it. If problems persist and I have more information, I’ll post back.

Blockquote Should one mention the Dave Method at this point?

Simon, thanks. I read through that. If this becomes a problem as my model skills and sizes grow, I’ll remember this.

Thank you all,
Kenton


#7

Did you right click on the .exe and choose run as administrator? If you did great, if not do so and choose repair as the option.


#8

Yes, that’s correct,.

I have a little more data on the instability. The USB docks I use (a Dell at work and DisplayLink at home) provide the adapters for the external monitors. At least three times now (but not every time), if Sketchup is open when I connect to the dock it has crashed. Perhaps it is not handling the disconnect/reconnect to the USB driven monitors it is displaying on as well as it might. This last time it produced an error report which I submitted. Hopefully that will help the team analyze the issue.

Kenton


#9

To be honest with you, I don’t think monitors are meant to be hot plugged. Try keeping them off when connecting.


#10

Hi RLGL,

Consider that Windows has supported docking stations with external monitors for decades. Available bandwidth in USB 3.0 and the driver technology has made USB docking stations with external monitors now the preferred method for business use. Also, none of my other programs crash because of docking.

Thanks,
Kenton


#11

I would add the words “sort of” to what you say about docking stations. In my experience they can cause all kinds of trouble. Starting with some models that won’t support OpenGL when plugged in. Or turn your monitor’s colour space to 16-bit when plugged in. Or don’t support FullHD or 4K monitors. Or support them only when plugged in with Display Port, not HDMI…


#12

Point taken, Anssi (and Simon, acknowledged).

My experience with Dell and Lenovo, the two brands I have used most has been good with only occasional docking issues, hence my position. One major exception: the day I cried out to the gods to unmercifully strike down Windows Vista, Microsoft and Lenovo when the drivers to support the driver model introduced in Vista were oh-so-not ready. And that illustrates where the issue often lies: quality of drivers.

I expect that with USB, the sorting out is still going on. Likely, software that uses heavy graphics will have more issues. I don’t use those very often. I’ve been doing more with GIMP (image editing) and some video in addition to Sketchup.

Thanks,
Kenton