New elements/tags show up automatically in scenes in sketchup

Does anyone have a tip on how I can avoid that new elements automatically show up in every scene I make. I am creating a storyboard for stage, and add new elements as I go. It is a bit a annoying to have to update every scene everytime I add an element. I am working in Skethup Pro 2023.

Scenes always show geometry that is not hidden or made invisible by tags that are turned off.
Adding entities to your model makes them appear in scenes unless you work in an invisible tag setting (not advised).

If you want to create new tags that are not visible in existing scenes use the Auto-Invisible Layer plugin from the Extension Warehouse. Then assign the new tag to the new groups/components. Of course as always, keep Untagged active and leave all geometry (faces and edges) untagged.


Thanks - I found that extension but it says that it says that is not compatible with the latest version…

Did you try it? It works for me in SU2023.

The page in the EWH just needs to be updated.

Great! Will try it straight away.

And it worked!