New tagged objects appear in previous scenes

One little wrinkle I have long struggled with is that when I create a newly tagged object, it appears in all previously established scenes and I have to go back through them (perhaps a couple of dozen) and turn their visibility off and re-save the scene. Surely there is a smarter way to deal with this. Please advise…well wait, I see on the left side a very similar topic. Will get back here.

Auto Invisible Layer. It works with Tags, too.

Thanks. I see that was the advice of previous similar topics. I am kind of leary of the extension approach perhaps due to a superstitious fear of unintended consequence in tinkering with the basic program. Wish there was a native solution.

That’s unfortunate since extensions add a ton of capability to SketchUp. I don’t think you will find it causes any problems with the software.

Maybe planning ahead to create your tags before you create scenes. I tend to work that way although once in a great while I wind up being given some change in a project that requires the addition of a tag or two. Then I do use the extension.

Thanks. I don’t seem to be able to anticipate all the tags I will need. In any case, I am checking out the extension, fingers crossed.

Okay, great, so far so good, thanks!

I did have this same need recently. I didn’t look for an extension solution, instead I went to my previous scenes, hid the new tags, and updated the scene. It wasn’t too painful.

Well, I got over hump of having to learn something new. I endured the tedium of manually updating perhaps dozens of scenes for a long time. So far the extension works as advertised and is a relief.

Make a keyboard shortcut so you can quickly turn it on or off when desired.

Thanks.

I could be wrong since I’ve only had it a couple weeks, but it seems like Auto Invisible Layer turns itself off–either randomly or when opening or closing. I keep thinking I have it on until a find scenes with new tags. I then see that it’s off and turn it on (again). Then a week later I’ll find new tags in my scenes and have to go through the process again. Does any one know if it’s supposed to open in it’s last state, or do you have to toggle it every time you open a new file?

The extension won’t automatically be running when you start a SketchUp session. You would need to turn it on. Give it a keyboard shortcut and turn it on when you start making new tags if you need it.

Okay, click on the extensions tab in the top bar and only the extension showing is Auto-invisible, got a choice of on or off.
The illustration in the Extensions Warehouse showed a little window with a list of tags which you could turn on or off. I have failed to access that feature, don’t know how.

Are you looking at the Tags panel under the Window menu? The screenshots are old and show the Layers and Scenes panels but you would be looking at Tags and Scenes in SU2020.