Need Later Version?


#1

I am trying to use SketchUp Make. When I try and open a model I made last month, I get the message that I need Version 16.1.1450 and that I have Version 15.3.330.

How do I get that?


#2

You must have had SketchUp 2016 or newer at some point to be able to create a 2016 file. You can get SketchUp 2017 Make here.

Your profile says you have SketchUp 2018 Pro. You can open the file with that.


#3

I had a trial version of SU 2018 Pro. My comuter is running 32-bit Windows 7 and the link you sent only has 64-bit SketchUp Make.


#4

SketchUp 2016 is the last one with a 32-bit version.

Sorry. You didn’t indicate that you need a 32-bit version in your first post. You can get 32-bit SketchUp 2016 here.


#5

Thanks. I downloaded that and “repaired” my version. When it was all done and I tried to load my old model, I got the same message. My model was created in a newer version of SketchUp.


#6

What do you mean you repaired your version? You said you have SU2015 installed. Did you install SU2016 Make? They would be separate installations. If you open SU2016 Make, you should be able to open that file.


#7

How are you opening the file, by double-clicking? It could be that the file association is still with version 2015. Try rightclicking and choose ‘Open with’
if you have different options, set the file associating to version 2016 or uninstall version 2015


#8

When I try “Open With” and select 2016, I get the message that my trial has expired. When I select 2015, I get the message that it’s an older version than the model.


#9

Did you install SketchUp 2016 Make from the link I provided? Or did you install 2016 Pro?


#10

It’s SU Make. It says it’s copyright 2015 and version 15.3.330


#11

Maybe I had better delete the SketchUp Make I have and then re-install?


#12

Then it isn’t SketchUp 2016 Make that you installed.


#13

Here the direct link:
https://www.sketchup.com/sketchup/2016/en/SketchUpMake-2016-1-1450-80430-en-x86-exe


#14

That worked! Thank you.

Now, as I understand, there is Sketch Up Pro, Sketch Up Make and Sketch Up Free?

I tried Free but it runs over the web and it’s very slow.


#15

Yes. Make and Free (Web) are for non-commercial, hobbyist use.

I haven’t seen it acting slowly. That could be your graphics card.


#16

#17

I would get the message: “SketchUp has stopped responding. Do you want to quit or wait”. I would hit “Wait” and eventually it would come back. This would happen about every 5 minutes.