Need help with Netstat

So every time I open my sketchup, my computer starts to run in low performace, so I checked my memory and noticed that this NETSTAT.EXE is showing up every second until I have to restart my computer.

I have tried to close the sketch, I tried to finish the netstat process, but nothing works, so I want to know if someone is experiencing this problem or knows the solution to this.

I can render everything at full resolution but I have to restart my computer after every image due to this.

I’m using sketchup 2017 with vray 3.4 and my settings are:

Amd- fx-8350
Amd rx-480 8GB
8GB ram

Did you install SketchUp correctly using Run as administrator from the right click menu?

Do you get the same behavior if you disable Vray?

1 Like

Pretty weird in my opinion.
Does your network some specific configuration? something like a VPN or proxy configured?
I recommend the following :
As Dave said install it using run as administrator
if the problem still persists I would check the computer to find viruses or malware even if only happens when SketchUp is open.
But keep in mind that SketchUp is free of viruses and malware.

What are you using Netstat for? It seems that you have set that to start automatically on computer startup, or that some other application is staring up innumerable copies of it.

Are you running my.sketchup or the native desktop edition of SketchUp? my.sketchup runs in your browser, and that flood of netstat processes could be an issue with either your browser or your network connection. The desktop edition does not use a network connection and so far as I know does not run netstat at all.

Is vRay attempting to NetWork render, or report home…

other extensions may also be trying that as well…

Amazon CloudFront connects whenever I run SU v17 but I;m not sure why…


Being that Vray is being used it’s the desktop version.

Google NETSTAT.EXE for plenty of good advice on that MS app function and use. It’s something that comes with Windows, but it’s not showing up as a running background app on my computer.

Vray runs a license server program, which probably is triggered to try to contact server.
Go to localhost 30304 in your browser and download latest version

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.