My sketch up pro glitching not openning properly

when i click a template this happens ive tried reinstalling it and using the 2017 version still no fix maybe this was caused by using a torrent file of a vray

Looks like a graphics card problem. Try updating the drivers and see if that changes anything. Go directly to the manufacturer of the card, don’t trust the operating system to tell you if the drivers are up to date.

Keep in mind that the graphics card you indicate in your profile is considered an entry level card. It is not high performing.

You say you reinstalled SketchUp. Did you do so correctly? That is, did you right click on the installer file and select Run as administrator from the Context menu?

By the way, your profile indicates you are using SketchUp 2019.

Where did you get the “torrent file of a vray”?

i think i got it from a classmate the 2 versions have been working properly the glitch happened when i installed the v ray

What is it? A cracked version? Get rid of it.

now i am using a trial now its working is this the fix i need ?

nope still not working when i open a file its still glitching

Before you go any farther, update the graphics drivers for your card.

i have updated my drivers still not working ive deleted all my installers still no fix pls help