NearMap Imagery Will Not Import

I have been trying to purchase NearMap imagery for a work project. I select my tiles, go through the checkout and the page pop ups with my confirmation number and Location ID. It says to continue on to import my files. Import button pops up, nothing happens. I click it and nothing changes. I even had someone else try it on their account and still no luck. Restart the program and the files are gone. Has anyone else had this issue? Any resolve? I really need theses tiles.

Hey There

I’m the product manager for Add Location.

So just to confirm is this what you are seeing:
1 You complete your purchase in your web browser
2 you go back to sketchUp and click import my purchase.
3 nothing is imported?

  • Do any error messages appear?
  • When you restart Add Location it does not say you have a pending purchase
  • When you tired another person’s account did you have to purchase again?
  • Can you try importing Digital Globe imagery to see if that will work for the region you are interested in?

Can you also private message me the user name(s) you used for purchasing and the order numbers? I will initiate the refund process?


We just pushed a fix for some errors. Could you see if the issue is still present?

I am finally able to press the import button and the next window says that the files are being imported and then I get an error message. I tried to restart sketchup, open the add location window, it prompts me to continue my download, but then I get the same error again. This is the furthest I’ve gotten in weeks of trying!
This is the error I receive

a small update. do you still need me to provide those other items? @Bryceosaurus

Hi Becky

I’m very sorry I missed your reply. Did you ever get your purchase cleared and refunded?


I’ve also had this issue, on three separate occasions now. I geo-locate the address, purchase the nearmaps image, go into mytrimble account and pay for it, it directs me to close the tab and return to the model to import the image, a popup window is open in the model which notifies me to wait for the image to download and to wait as large images can take several minutes (and so I then wait), the popup window disappears, and voila - no image.

It has also worked for me several times, following exactly the same process, so it’s very hit and miss. I’ve tried contacting Sketchup help, and all they do is ask me to go through a process to get a refund. Hoping that there is a fix as I actually need the images…