Nearmap data purchase has never worked for me

I am a would-be occasional user of Nearmap data, but I have tried to purchase the minimum 200 squares on multiple occasions and it has never once worked for me. On the plus side, despite having multiple times placed an order and put my CC info in, I haven’t been charged, but the inability to use the service is incredibly frustrating. I wonder if it’s something to do with my account. I have two accounts associated with my email address and I’m not sure if perhaps that’s causing an issue. I reached out to support before and they just replied back asking for more information. There’s not more info, I attempt to geolocate my model, select Nearmap as my provider, select 200+ tiles, go through the purchase process in the browser until it’s complete, never receive a confirmation via email and when I hit done or purchase complete or whatever it is back in SketchUp it gives me an error. Does anyone else have this issue? I’ve made it work in the past by just scaling better imagery data from other sources, but would really like to have the better data already scaled and positioned and just work for the $17 on certain projects. Any help appreciated.

Have you contacted support to help troubleshoot why the purchases aren’t going through? Maybe @colin can take a look.

In the meantime, you can check out the Placemaker extension - it uses a credit system for purchasing high-res aerial imagery - as well as terrain and buildings as well. https://www.suplacemaker.com/

I don’t see any attempts to buy nearmap tiles, from you or your colleagues. Don’t know why they didn’t get through the system.

I tell you what, I made a screen recording and I’ll send you that in a DM. It also highlights another issue I have where the window size is all funky.

Is Nearmap even available for SketchUp 2018?

Fair question, I’m currently using 2021 and just haven’t updated my profile.