My sketchup 2017 doesn't work

Hi everyone,

I’ve just downloaded sketchup 2017 but when I run the program it doesn’t work. I tried sketchup make and sketchup pro 2017 but none of it works. What can be the problem?
Thank you!

Can you be more specific please? Does the software not run at all? Does it just give you a blank screen? Tell us more, thank you.

Thank you for your reply. When I run sketchup it says: SketchUp has produced a bug splat.
Then you can describe what you were doing before the crash and you can send error report.

sub, 29. jun 2019. 12:58 Ben W via SketchUp Forum je napisao/la:

Bug Splats on startup are generally caused by a bad graphics card or its drivers. The graphics card you’ve indicated in your profile is not suitable for SketchUp.

Is it possible you have a different one and just entered the information incorrectly? Check to see what it is, go to the manufacturer’s website and get the latest drivers.

Please also correct the SketchUp version in your profile when you are correcting the graphics card information. There is no SketchUp 2019 Make.