Bug Splat on startup

Hello everyone,
I’ve been googling all over the place to try and get this working but having no luck. When I open Sketchup Make 2017 on my machine It just dies with a bug splat. I’m not sure how to read the dump file it creates though.
https://openweb.vip/whatsapp-web/ https://19216801.onl/
It used to work fine on my machine but this is the first time i’ve tried using it since updating to 1903 on windows 10.

Is anyone else having issues or does anyone know how to fix this? I’ve re-installed it a few times and tried different things but no joy

Cheers.

Most often Bug Splats on startup are related to deficiencies in the graphics card and/or its drivers. Your profile seems to indicate that it’s an integrated Intel card although 3.0 is not a graphics card model number. It would help if you would correct that to show the real graphics card model.

Go to the Intel site, get the latest graphics drivers, and install them.

Also make sure you’ve installed SketchUp correctly. Sign in to Windows as you normally do, find the downloaded installer, right click on it and choose Run as administrator. Do that now to make sure and when presented the options, choose Repair.

Are you using SketchUp Make or SketchUp 2019? Your profile lists both versions.