My model went broken after I downloaded the 2020 version ( used to be 2018)

Does anybody encounter this before? I don’t know what is this problem called and I can’t solve it until now. Please help me

At first glance this looks like a graphics card issue. You can try Window Menu>Preferences>OpenGL change the state of the Fast Feedback (if on turn off if off turn on) then restart SketchUp to see if it improves. It is possibly caused by a behind the scenes update in the graphics card driver pushed by Windows, you can try to roll back to a previous driver.

Your profile says SketchUp Free for web, but your questions is about 2020 so which is it? If as I suspect this is about 2020 pro, and you are migrating from 18 pro does the file look the same in 18?

to confirm that this is a graphics card issue upload your model here so someone else can open it to check it.

Ive tried to turn on Fast Feedback and it didn’t work.

Ya. Im using SketchUp Pro 2020. No. It works fine in 2018 Pro. But when I exported it to 3d max 2018, the model happened this way too.

I did tried to upload the skp file but it just stopped in the middle while its uploading here.

You might have to use a file sharing service like google drive or dropbox if the file is too big to post here.

Something is unhappy with that file. I cannot open it in 20 or 18, crashed in both. Does this file open OK for you in 18? If so can you copy paste geometry out of it into a fresh file? Do you keep your files on your local drive or are you working off a cloud service?

OK Progress. Should it look like this?

I have remade a clean file in the 2020 format. I also purged unused items and reduced the file size to less than half at 51mb. Try this version.

https://drive.google.com/drive/folders/1PQMRDAAl7MuFlB5-1qSzurNGo3Zj4OkZ?usp=sharing

The model is very demanding for some reason. I was able to open it in SketchUp 2014 (it’s a 2013 file), then save that and open the new file in 2020.

There are odd things too. Selecting a component shows nothing in entity info. Hiding almost all layers, until there were just lines on the ground, still performed badly. Copying those lines into a new file then performed smoothly, and had a working entity info.

Going to bed now but I left SketchUp trying to paste the whole model into a new file.

2 Likes

Still same thing happened. Does this has anything to do with my graphic card?

It might have. Have you tried downloading and installing the latest driver from the Nvidia website?

Your file opened quite OK for me. It has unused items that can be purged in Model Info.

I managed to copy and paste the model into a new file. It will have lost the scenes, but it does at least perform normally.

Here’s that version:

If it works ok for you, you could take one of your non-working versions, select every and delete it, go into Model Info, Statistics, and Purge All. Save As to a new file, then copy everything in my file and Edit/Paste in Place into your new model. Save. That should leave you with a workable model that has the original scenes.