My Model Disappeared and zoom extents did not work. Please help :(

I have looked at the other questions people have posted and tried zoom extents, tried to seek out the hidden geometries and I cannot find a solution. It just looks blank. Any idea what’s happened to my model?? (my file is too big to post here)

you will need to find someplace that can host it and share a link… otherwise we are just guessing at what it MIGHT be that is causing the issue.

Some people use WeTransfer.

Thank you for the suggestion! here is the link WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free

I’m seeing a lot of components and a number of custom textures all contributing to the overall size, but I can’t find anything modeled from them.
Have you saved it to Trimble Connect as well as your desktop? If so, try going through the version history.

I see. So should I re-start at this point? I have not tried Trimble connect before an have been downloading them to my laptop only.

Basics of SketchUp at

  • learn about groups and tags
  • learn about Purge
    Keep your geometry close to Origin
    Check the models you insert from 3D Warehouse

1 Like

Thank you so much! After this I will defiantly be looking to educate myself better :slight_smile:

1 Like