HELP! I have somehow got lost in my drawing, zoom extents won't work!

Hi, i am extremely new to SketchUp as well as new to this forum. I am desperate for some help as i have somehow lost my Work.

I have used Zoom extents before to relocate to my drawing but now this wont work. I can’t even seem to find the horizon. All i can see is blank space. Annoyingly i am towards the end of the project so to lose all those hours of work would be a nightmare.

I hope someone can help or might have had a similar experience?

Thank you so much in advance.

Very likely you have some little scrap of something situated at a great distance from the rest of the model. Share the .skp file so we can see what you’ve really got going on and help you fix it.

1 Like

Hi Dave, thanks for reaching out, i really appreciate it.

It’s telling me that the file type is too big to upload. It’s 88MB? Surely thats not too big?

Your profile information is rather contradictory so I don’t know if this would work for you: Open the Outliner, select an object that you know is in your model and select Zoom Selection from the context menu. Getting rid of stray objects in outer space is of course a priority.

Upload the file to DropBox or WE Transfer and share the link.

You can share via a cloud service (dropbox, Google Drive, WeTransfer etc…) and post the link here.

Here is the link:

When you hit ‘Ctrl+A’, does it select anything?

If so, it could be as DaveR says, some scrap far away from the model you were working on and you need to clean your workspace.
If you are sertain your model is near the ‘Origin’ (0,0,0), you could ‘zoom extend’ and then zoom out even further. then select an area you are sertain your model is not situated at. Keep an eye on your ‘Entity info’ window to see if you have selected anything. If so, and you are sure it is not part of your model, delete it and try ‘zoom extend’ again.
su zoom extend lost model

If not, your workspace is probably empty and the model got lost somehow.
With a little bit of luck you could try opening your backup (skb) file to see if that stil contains your model?
su rename and open backup

Else it would be apreciated … [you already shared the model] :slight_smile:

The camera was balled up. No little bits of geometry at a great distance although that is a very common cause. I switch the Camera to Parallel Projection and clicked Zoom Extents Then shifted back to Perspective and that seems to have fixed it. I also found some incorrect tag usage and a lot of unused stuff to purge.
Screenshot - 8_8_2023 , 8_18_01 AM

Screenshot - 8_8_2023 , 8_18_20 AM

File size reduced by 79%. I’ll upload it to DropBox and share the link.

Not all hero’s wear capes! Thank you so much for this, you have definitely saved me a lot of stress.

Thanks for pointing out the problems, like i said im super new to this so there’s probs loads wrong but im sure I’ll get there eventually.

Can’t thank you enough :grinning:

1 Like

I noticed the same thing. @colin might have a say about what happened. The Outliner trick I talked in my post worked too.

I tried that first but it didn’t work for me.

Also, it should be noted that, on occasion, @DaveR does wear a cape…


To help achieve your goals, some time spent at the SketchUp Campus and at the SketchUp - YouTube channel will be very worthwhile. Both sites are from the SketchUp team. On the YouTube channel, pay attention to the Square One Series and Level UP series. They cover the basics for each tool.

Shh … It’s really just a Sponge Bob beach towel but don’t tell anyone. :wink:


Does @TheOnlyAaron know what it takes to get the camera to get so badly balled up that a simple Zoom Extents won’t fix it?

I feel like I have seen this before… switching camera between Perspective and Parallel helps, but I have no idea why it happens…

I’ve seen plenty of models from others who have had this issue but I’ve never induced it myself, even when trying to do it. It would be interesting tofigure out how it happens, though.

Another trick that I tried and it worked is to start a new model and then import your file in it.

I tried opening the file again. Now Zoom Extents worked, for a change, and the resulting view was upside down, so probably control+orbit has been part of the workflow.

1 Like