My model disappeared and I don't know how to retrieve it. Still have components

So I was working on a model. I had just grouped it all together and was rotating around and I must’ve accidentally clicked something because it all of a sudden disappeared and I can’t seem to find it at all.

• I still have the components in my components list but can’t drag them out of my list.

• I tried turning on hidden geometry and it hasn’t found anything. Also tried “unhide all” and nothing showed up.

What the hell did I do? Is it possible to recover what I made?

Upload the file so we can see what you’ve got. I expect the solution is easy enough if we have the .skp file in front of us.

coffee table v.1.skp (305.5 KB)

Here you go. Thanks for the quick reply.

You managed to get the camera a long way from the model. This is what I found in your model. Is it supposed to be that large?

coffee table v.1.skp (425.9 KB)

Thanks Dave for your help. I’m a newbie and to be honest with you, I’m not even sure what I’m looking at. Model was supposed to be a coffee table top.

How would you recommend i zoom in enough to find my original model?

Also, is there a reason why I’m unable to drag my components out from the list?

You probably won’t see them in the current state of your file.something triggered it to span the universe.
If you rightclick on it in the component panel, choose ‘Select instances’ and then in the menu on the top choose [menu] Edit > (name of component) > zoom selection

Download the one I uploaded. It’s already fixed.

Looks like they can be dragged out from the list but they would be tiny relative to your big disks so hard to see.

Ahh yes but unfortunately I have only the free version. And for some reason I am unable to right click on any of my components nor the component panel.

Ahh yes! Thank you Dave. Very much appreciate your and everyone else’s help.

Are you able to tell me what you did to retrieve the model again? So I know for future reference?

I used an extension in the desktop version to reset the camera position. Unfortunately the Free web version doesn’t give you the option to use the extension.