My geolocation does not work

When i open it is just a blank screen with continuous spinning wheel. I can type in the location address but nothing happens. My internet connection is solid.

Are you still using SketchUp 2021 as your forum profile indicates? If so, Geo-Location and other web-based services stopped supporting SketchUp 2021 months ago. This was announce in the last quarter of 2023 and support for 2021 ended at the end of January.

No, i am using the latest version of 2024.

Please update your forum profile.

Did you install SketchUp 2024 correctly? On Windows that requires right clicking on the installer and selecting Run as administrator.

Also make sure the Add Location extension is up to date.

how do you update your profile. i am on there and it does not tell me what version i am on, let alone how to change it.

I still do not have add location feature. i deleted the extension and downloaded the 2024 version but it is still doing the same thing. this support is too slow. please call me to get this resolved. thank you.

This is not SketchUp support. This is an user forum with answers coming from other SketchUp users. Support is accessed through the SketchUp webpage, Contact Us | SketchUp Help | SketchUp

it took DaveR 4 minutes to answer your initial message.
then it took you 9 days and 22 hours to come back and answer his.

:upside_down_face:

1 Like

Click on the L in the teal-colored circle at the top right of the forum page. Then click on the person icon followed by Preferences and then Profile. Edit your profile with the correct SketchUp version and other details. Scroll to the bottom and save the changes.

You’re on where?

Look! I’m a SketchUp user like you. I am NOT a Trimble employee. No one is paying me to try to help you. If I’m to slow for you, tough. I responded to your original post less than 5 minutes after you made yours. That was a waste of time since your profile is wrong. Then it was nearly two weeks before you could be bothered to come bck to this thread. Who is too slow?

Thank you Dave. I am truly sorry.

I am a bit new to the forum and thought I was communicating with support team.

I’ve had very few issues until the subscription came along.

I really appreciate your help.

My forum is up to date now, thanks to you.

I have contacted prosupport for my add locations trouble that I am still having.

Lenny