Moving Objects around in SketchUp 2019 Pro: Windows vs MacOS. Stuttering on Windows!

Hi Guys,

In the past I´ve done everything with SketchUp on my Macbook, connected to external Monitors. Recently I worked with SketchUp on my Windows-PC. When working with large files, the overall performance is better on my Windows-PC, but I noticed one strange behavior:

Not everytime, but very often, when I move Objects across other Surfaces, the movement is very stuttering. On Mac it´s much more smooth. Although my Windows-PC is more powerful than the my Mac. To find a solution, I turned of Anti-Aliasing, turned on “fast feedback”, reduced the Resolution of the Screen and plugged out my 3d-mouse. Nothing has changed. Then I opened the same file on my other two Windows-Machines, but the problem remains.

I also compared the Single CPU-Performance-Rating (Passmark CPU Mark https://www.cpubenchmark.net/singleThread.html), and it turned out that my Macbook is the slowest Computer:
Windows Desktop: Ryzen 9 3900 x 12-core: 2,730
MS Surface 7 Pro: i7-1065G7 4-core: 2,503 (this little Device is quite fast)
Alienware Laptop: i7-8750H 6-core: 2,359
Macbook Pro: i7-7820HQ: 2,047

So I assume, this is not a problem of my Desktop-PC, but rather could be a Problem only existing on Windows. Also it´s not a problem with that particular SketchUp-File. Because I have the same Stuttering problems in other Projects as well. :thinking:

Could you please take a look at my short video I recorded, which shows both Win and Mac:

And here is the link to my SketchUp-File, shown in the Video (SketchUp V 2019). Would be nice if someone could test this behavior with my file:

  • deleted -

Greetings, Peter

Are your 3D graphics settings correctly configured? Are your display drivers up to date?

Yes, on all 3 Machines. What Do you mean by “correctly configured?”. I use the Stardard-Nvidia-Drivers and changed nothing. And I don´t have an problem with other CAD-Software like f. e. Allplan.

In the Nvidia control panel 3D application settings, SketchUp must be set to use the Nvidia card instead of an integrated graphics chip, if present. In SketchUp, Window menu>Preferences>OpenGL will show which graphics card is currently in use.

Thanks! The right one is working.