Moving components in Sketchup

Hello All

I am currently using Sketchup 2018.
Saved a drawing last night and today I cannot move components.
Tried opening a new drawing, created a component and cannot move it.

Hopefully someone could help me with this.


It would be a huge help if you share the .skp file so we can see exactly what you’ve got. Maybe the most common reason would be that the component is locked. If when you select it there’s a red bounding box, you would need to unlock it.

Hello Dave

Please find attached file

Thanks for your response

Electrical shed.skp (74.2 KB)

What component are you trying to move?

I haven’t yet found anything that I can’t move in that model. But it’s getting tedious trying every one. The answer to @DaveR’s question will reduce the effort!

Hello All

I have resolved my problem.

Much appreciation for your responses

How did you resolve it?

I happened to have your model open from yesterday and noticed something that I will mention as a way to improve your modeling. I see that you have created distinct components for each orientation of an instance. For example, <92 1/4" Stud> and <92 1/4" Stud 2> are identical except for rotation by 90 degrees. You could rotate instances of <92 1/4" Stud> to get the same result with one fewer component required. Same for other similar examples. You did model the two rafters as flipped instances of the same component though (just a special case of transformation).

1 Like