Sketch no longer has components after Reload

I created a Sketch and saved it. Along the way I created many components and saved along the way.
Worked on the project over several days.

Today I had to reboot.
Reloaded my sketch and now I no longer have components to select in the drawing. Anything I click on is just a face, and the Move tool is behaving more like the Push/Pull tool. Trying to copy something only copies the face.
My components are in the component library. Components behave correctly if pulled from the library.

Am I doing something wrong?

Which version of SketchUp are you using? Your profile and the category you posted in are contradictory.

It was originally done on the web version. Download the sketch and opened in 2019. Same issue.

Are the components still shown in the In Model components collection? Can you upload the SKp file so we can see what you’ve got?

Dog Cage.skp (700.8 KB)
One side is missing because I made a different side to let my wife pick the one she liked. Was going to simply copy the parts on the other side when I found the problem.

The components exist in the In Model components collection although some of them seem to be a different size which leads me to believe you did some scaling in there somewhere. Did you model the whole thing and then start making components? I see signs that you might have done that. If you did, and you did not have Replace Selection with Component checked on, the components would have been created and would show in the In Model collection but the model itself would still be loose geometry.

Look at the green component. It has an additional edge running its length and the blue face at the end.

Strangely, the first component you created was a simple wireframe box. What’s that about?

If you were saving while on the web version of SU, you can access historical versions from Trimble Connect.

1 Like

As you can see it was my first project. I too am curious about the wire frame. The blue edge piece was a change and I guess I picked up an edge somewhere.
I did scale these pieces as I went along. I created components as I went, but I was constantly changing things. I’ll look for the “Replace Selection with Component” option.

Thanks. This was a web version creation.

Best work flow is to draw a part that you would make in wood and create a component before you move on to modeling the next part. This will always prevent the issue you have in this model. If you need to change the size of a component after it is made, and the Scale tool is appropriate for the job (it isn’t always the right tool) either open the component and scale the geometry inside it or after scaling the component, right click on it and choose Scale Definition.

1 Like


Another problem I was having is copies of a component were not always changing size when I changed one of them. It worked for those light purple rails (with the groove), but other times it didn’t. I was sure this was user error. Was this because I wasn’t scaling the geometry as you said?

If you scale a component instead of opening it and scaling the geometry inside, you’ll only change the size of the one you are scaling.

FWIW, in the case of this project, I think your best bet and easiest fix would be to start from scratch making sure to make components of the parts as you go along. If you shove the existing model back along the green axis, you can use it for reference where appropriate as you draw the new model at the origin.

That’s the plan. This was just a way to work some things out before building & cutting. I saved myself a bunch of work just playing around with it, and my wife got to pick the design options. Rather than her walking into the garage when it’s 90% complete with “But I thought…”

…you were going to build me a tire swing."

:smiley: :smiley:

1 Like