Unable to create a component

components

#1

Have been using Sketchup for a long time to create models of things I want to build in my woodworking workshop. Currently, I am using Sketchup 16 on Mac OS X 10.11.2.

I began making a model of a chest of drawers with a hutch on top. After completing the chest (everything was going well) I made one side of the Hutch, but was unable to create component from the drawing. I would select the appropriate part of the model, right click on the selected parts, select “Create Component” making sure the “Replace selection with Component” was checked, then clicked on “Create.” If I then tried to select the part that was supposed to be a component, It acted like a component hadn’t been made. If I again select the appropriate parts and right click, the “explode” function is grayed out, but the make component is still there. Repeating the process does’t help. All of the components of the lower cabinet that I made first are behaving appropriately.

I even tried deleting all of the Hutch parts and starting over. That didn’t help
Then I deleted all of the Hutch parts, selected all of the lower cabinet, copied it then pasted it into a new file, problem described above persisted.

Then I tried making a second element (a shelf). The shelf acted as if it were part of the side. I was unable to make the shelf into a component, same issue as above.

This all happened very suddenly. The session during which the problem started was the same session that allowed me to create the lower portion of the piece.

What did I do to make the behavior of the Make Component function no longer work?
How do I fix the issue?

Thanks
CyberBiker


#2

Could you share the file? If you don’t want to post it publicly, send it via a private message and i’ll take a look.

Generally it is more efficient to draw each part and make it a component before moving on to the next part.


#3

No problem sharing the file.
Normally, I make components one at a time as I go along. Since I couldn’t make the side a component, I tried making the shelf a component. I have found that creating the component as early in the modeling process as possible make things easier for me.

Shackdrawers4.skp (97.9 KB)


#4

I tried making just the hutch in a new file, that seems to work


#5

I didn’t poke at your file very much but the two lower case sides and the top are components.

My workflow would be to draw the left case side and make it a component prior to doing any other modeling. I’d copy it to the right side and flip the copy to make a mirrored copy of the original. Then draw parts to fit between making components as I go. I never leave loose geometry when moving on to draw another part.

Glad you got it to work.


#6

Yup, that is true. I made the lower case side, made it a component, made the top, made it a component, Made the bottom, made it a component, etc. When I was done with the lower case, I drew a 3/4" by 12" rectangle on top of the top, pulled it up 30" then tried to make it a component. That is when I ran into trouble.

dave


#7

Hmmm… Just leaving for home. I’ll look when I get there.


#8

Something Odd has occurred. I opened the file I sent, redrew the side (3/4, 11 3/4, then pulled 42") Selected the resulting part, right clicked on it, “make component” named it Hutch Side, same problem. Then I re-selected the same part, right clicked “make component” gave it a different name (Hutch Side 2), it is now working properly. Now everything seems to be back to normal.

Guess Sketchup didn’t like my name very well.

Thanks for the help.

Dave


#9

Give me a few minutes to get situated.


#10

Hi Dave,

I had another look and it seems like everything but the side for the hutch is a component. The Outliner shows them alright, too.

One thing you need to change about your work flow is keeping all edges and faces on Layer 0. Then should not get assigned to other layers. Only the components should be. And Layer 0 should always be left as the active layer. When I opened the file, I saw that the layer called Hutch Surround is active.


#11

Thanks, I was not aware of the edges & faces needing to be in layer 0. I have always made different layers for each part of the model. Not sure I know how to put components in different layers after I create them in level 0. I have done it the way I do so I can hide whole parts while I work on a sub section. By unchecking the layer for the Surround parts, for example, I can work on the drawers without the surround being in the way.

Will do some reading about workflows to come up with a better way.

Appreciate your time and comments, Thanks

Dave


#12

Check your PMs in a moment


#13

Using 2017 up to date.
Simple example:
Start with a clean launch of sketchup - no file specified
Delete Chris
Draw a rectangle
Extrude the rectangle
Select the Box
Right Click->Make Component
Now select a side on the Box - there is no blue bounding box and the side (face) now has focus. If you hit delete you delete that face - IT IS NOT A Component.
Now go to your Components bin and the component IS in the inventory.
Drag it out and it IS a component.
Rebooted, reinstalled - cannot think of anything else.
Any ideas?


#14

So you are selecting a single rectangle (face) of the extruded box and trying to make it a component? Is “Replace selected with component” checked?

This would indicate you aren’t checking that box. If you aren’t selecting all attached geometry for the component, that box needs to be dealt with.

What happens if you select the entire box and create a component?


#15

Yep words are important. I meant to say Select the box!


#16

Make sure that when you use ‘Make Component’ you check the ‘Replace Selection with Component’ box in the dialog.
Otherwise the component is made and added to the model’s components list, but without an instance placed - leaving the previously selected geometry in place.

This can occur if the selected geometry has some non-selected pieces attached to it, which might otherwise be left behind after the component is created.
So SketchUp can quite logically assume that although you are making a component you do not want to remove the selected geometry… The assumption/choice now continues into other similar selection-to-component operations [at least since v2016?]…


#17

Thanks - that was it.
I have been using SketchUp since version 8.
You think I would have caught that!
I should know better. I must have fat fingered that dialog and never noticed it.
Thanks again for the help!
The fool says bye.


#18

Note: having the Create Component dialog remember your last choice on the “Replace selection…” box was a recent change. In the past it did a sort of auto-detect based on whether the selection was touching other loose geometry. That led to a lot of errors, so they changed it.