Two SketchUp issues occurred in Version 17.2.2555


#1

Hello I have latley two bug that happens to me when I work with SketchUp. maybe you guys can help me if this are issues or a new design? Some help would be nice maybe a walk around for this problems.

First bug I had

The first component that is created in a project does not behave like a component but is saved in library as a component but still behaves like a normal SketchUp object and not like a component. After the object is turned into a component it behaves still like a normal object in SketchUp, so you must paint each face separately and there is no blue boundary box around the object to show the user that this is a component. The object itself is saved as a component and when drag and drop the comp out of the library it behaves like a normal comp

Str:

  1. Start SketchUp 2) Now create a simple object in SketchUp
  2. Now make out of this object a component
  3. click on the object that is now a component

Bug number 2

A saved component will get a live updated from the edited component in the scene even a saved component should not be affected by changes in the scene. It worked for me normal before a saved component in the library was never effected by a change in scene, but now it makes no scene to save a component when it will be updated with the change I do in scene.

Str:

  1. Start SketchUp
  2. Now create a object in SketchUp
  3. Turn the object into a component
  4. Now observe if the new component is saved in component library
  5. Drag and drop the saved component to the scene the old one can be deleted
  6. Observe the icon from saved component
  7. Now start editing the component in the scene
  8. Observe the icon of the saved component

I hope you could give me some answers or help. Does anyone else have this problems?

Greeting and thank you


#2

Neither one of these is a bug with the program. It sounds more like bugs in the way you are using it and your understanding of it.

This sounds like a case of having other, unselected geometry connected to the selection when you make the component. When you create the component, you are forgetting to tick the box for Replace Selection With Component.

If you are dragging the component in from the In Model library and editing it, its thumbnail will most certainly reflect the changes. That’s expected behavior. If you don’t want to modify the original component, leave the original copy in the model space. Drag in a new copy and use Make Unique on it to break its relationship to the original. Change its name if you wish and make all the edits you want.

Better, save the component to a local collection for later use before you modify it.


#3

Hi DaveR

Thank you for your answer I will check directly if I did here something wrong and try it with your tips provided

Greetings and thx


#4

I used before 2016 and updated to 2017 had this changed made in 2017 version because I can not remember this behavior before but thank you for the information provided


#5

Neither of the things you describe are new to SU2017. If you did the same things in any earlier version, you would have had the same result.

They did add a feature in SU2016 where SketchUp will remember your choice for Replace Selection with Component so if you check the box once, it should remain checked going forward.


#6

Okay, so it seems my misunderstanding I will do it then as you suggested will save some confusion on my side thanks for the fast feedback helped a lot


#7

This topic was automatically closed after 91 days. New replies are no longer allowed.