Moving an Object is jumping around

All of a sudden when I try to move an object it is jumping around and not going to where I want it. I turned off the length units snapping and that did not work. I must have pushed a hotkey or something? Any help would be greatly appreciated! I researched other answers as well and most seem to lead to the length unit model info.

I’d probably start by trying zoom extents to see if there’s a bit off in the distance.


I looked…nothing hanging out there.

How about a recent change to your video card or it’s drivers?

ummmm…I haven’t done anything that I know of.

Since you’re on a Mac you automatically get video driver updates with other OS updates if there are any.

Since you have an AMD Radeon card which are known for their less than ideal support for OpenGL, it could be a GPU driver issue. You might try turning off Hardware Acceleration in Preferences>OpenGL.

Another thing that might cause this behavior is working at a long distance from the origin or having geometry at a long distance. It’s best to keep everything as close to the origin as possible.

So here is what is going on. I had turned off the length unit snapping, then saved it. That worked once, then it started snapping again to a set length. (I had put one in there as a test) It is snapping to that length even though it is not turned on?! I tried quitting SU and restarting, I tried restarting my computer and I tried creating a whole new file…nothing has worked so far.

Can you post an example SKP file that does it?

I may be totally wrong here… but… when I was really new with Sketchup and I had trouble moving objects exactly where I wanted to, it was due to 2 reasons.

  1. When you move an object, I found out it was best to first have the object selected, then click your mouse when it is away from all objects so that when you start moving, the Sketchup inference engine is not forcing your object to snap or orient a certain way. (I had more precision in moving if I was sure to click away from all other objects).

2.Another problem I found out… is that when I created objects/components like text and it had a “glued to” default setting so when I tried to move the text, I could not move it with any precision because it was trying to stay glued or snap to other objects. So even if you make components to have control over one big object, you might want to check/edit each object to make sure it’s not “glued to” for settings.

Once I realized these two problems I had, I now can orient and move anything I want with no problems.

I’ll try. I’ve never done that before!

Problem Child.skp (117.0 KB)

I’m looking at your file. What is it you want to move and where to?

No problem with moving in that model here, maybe you can create a short screencast that shows the unwanted behaviour?

A quick note on your model, you are using layers incorrectly.
Never change the left radio button away from Layer0, in other words always keep layer0 the active layer.
Never move raw geometry to any layer other than Layer0. Raw geometry being edges and faces that haven’t been enclosed in a group or component.
Only assign Groups and Components to layers.
Layer are only for visibility, they do not separate geometry.
Groups and Components separate geometry.

1 Like