Moved item in Sketchup and dims warped in Layout

I’m drawing a house plan. I did the dims in Layout and had to move the plan over a bit in Sketchup. When I updated LO it warped the dims sending them all directions and they are no longer aligned with anything. How in the world do I fix this?

Can you share the LO file so we can see exactly what you’ve got going on?

Sure…
FLOOR PLAN.layout (2.3 MB)

It gets even worse if I deleted the second story part and try to center the 1st story, which I really need to do.

If I have to delete them and start over, I can. How do I keep this from being a problem again?
FLOOR PLAN.layout (2.2 MB)

There’s a couple of issues that I see immediately. First you are using the Last saved SketchUp view for the scene. This makes the issue with the dimensions very likely to occur because you don’t have a fixed camera position like you would if you created a scene. Second, you have modified the Camera properties in LO and this increases the chances of issues with the dimensions moving.

Best practice would be to set up at least one scene with the Camera setup as Parallel Projection and the standard Top view. Then use the scene for the viewport(s) in LO and don’t do anything that modifies the Camera properties (results in the Reset button and dark gray background in the Camera section of the SketchUp Model panel.) After setting the scale for the viewport you can drag the edges of it to adjust what is being shown. No need to move the model in SketchUp. At this point I would suggest going back to the SketchUp model, setting up a scene, saving the changes, uupdating the reference in LO and then choose that scene in the SketchUp Model panel. After that you can move the dimensions as needed to get them where you want.

Thanks! Some of what you said is greek to me. I’ve been using sketchup for years, but only used LO when I had to scale and make a PDF. That’s my knowledge of LO. I understand scenes as far as keeping the plan where I want it, but that’s it.

I have a scene on SU currently, but forgot to select it in LO. I selected that scene and nothing changed when I updated it on LO.

Yes. There’s a scene in the SketchUp model but the camera is not set to Parallel Projection. Change that and update the scene and save. Then update the reference in LO and reset the Camera properties in the SketchUp Model panel.

Ok, I did as you said in your last response and this is what I get. I did move the model in SU first, because that’s where it needs to go. Maybe that’s part of the problem?
FLOOR PLAN.layout (2.3 MB)

Most definitely that’s the problem. There should be no need to move the model in SketchUp, though.

Check your PMs.

This link may help with the confusion: Layout. In Youtube I used the search term “Layout” while in the SketchUp channel. There is a ton of good info there.