Layout keeps shifting model position in plans and elevation


#1

I am an architect using Layout to prepare town planning drawing. I have created the model in Sketchup.
In layout l have been setting up all the drawing required for planning. i.e. Plans, elevations and sections.

I have been placing all the dimensioning information, labels, notes onto the layout drawing and all looks good.

However when l add and change the Sketchup model and go back into Layout sometimes the plan and or elevations have shifted out of place. Ie the labels and notes do not line up. Plus the plan might only half show as if it has been moved beyond the container box.

Im sure there is a simple answer to correct this occurring going forward.

Assistance would be a big help.


#2

Have you assigned scenes in SketchUp and use these (unchanged) in your viewports?


#3

This could happen because you move something in SU and forget to update update the scene. If you do that, the camera setting will be looking at something that has changed position without itself moving.

One of the slight drawbacks of dividing model space and paper space (to use Autocad terms) between two software packages is that you have to remember the sequence of operations to make sure LO shows what you want. So you not only have to update individual scenes, you also have to remember to save the SU file. Then you have to update the imported file in LO. It’s a bit of a faff TBH but you do get used to it.


#4

Thanks for your comments.
Yes l have assigned scenes in SU for all elevations and TOP sections for plans (ground, first and roof), plus cross sections.
As l’m new to Sketch up l might have gone into the scenes and adjusted (unknowingly) something that has changed them. as it doesn’t always happen.

Are there any critical do’s and don’t for working in SU on this type of presentation for architectural plans…where the final drawings are the one’s in LO.

I assume you set up the scenes you want to place into LO and then don’t change or adjust them. Therefore if you go back and need to work further on your SU model do you setup a working scene??.

Another question. Do you use layers in LO when placing the information over the SU scene. Ie dimensions, labels etc. Do you place the SU scene on its own layer and lock it??.


#5

In the advanced scene settings, in SketchUp, you can see that there is a camera position tick box. Setup your camera for the top view or elevation or whatever, and never change it again.


#6

Where do you find this on a mac. Is it a top menu pull down


#7

Yes, look to the top menus. Window > Scenes


#8

Create scenes in SketchUp that show the model as you need to show it in your LO document. Make sure the scenes a saving camera properties and that styles are updated for the scenes.

If you want to be able to show the model to a specific scale in LO, make sure the camera is set to Parallel Projection in SU.

Make sure you are using SU’s layers correctly. That is, ALL edges and faces are created on and remain on Layer 0. Only assign components and groups to other layers.

Turn off the layer visibility for entities that are going to be seen in the scene.

In LayOut:

Before you get too far into placing viewports and other entities, at least set the paper size. Use the largest paper size you expect to print that document on. Best would be to create your own template with the correct paper size, layers for entity types and things like borders, title blocks and boilerplate stuff.

After getting the first viewport in LO by using Send to LayOut from SketchUp, set it to the desired scene in the SketchUp Model panel. Don’t touch the Standard Views drop down or the Ortho button. The settings you could make there are already part of the scene you’ve created in SU. Select the scale if appropriate–your plan views for example.

Do not double click on the viewport or do anything else that makes the scene show as modified in the SketchUp Model panel. You can drag the edges or corners of the viewport as needed to resize it but there’s no need to do anything that creates a modified scene.

As for layers in LO, create layers by the sorts of entities you’ll have in the document. Text, dimensions and other things that you might want to show over the SketchUp viewports need to be higher in the list than the layers for the viewports. I frequently stack viewports so I have several layers for them. Here’s an example of the layers for one of my templates.
Screenshot%20-%2010_18_2018%20%2C%207_46_22%20AM

If you need to go back to SketchUp to make changes to the model and you need to change scene-specific things like style settings (section cuts display is a style setting) shadows, camera position, layer visibility state etc., make sure you update the scene after making the changes. Then save the SKP file. In LO, right click on a viewport and choose Update Model Reference.

If you keep those viewports attached to the original scenes in SketchUp and don’t do anything to modify the scene in LO, you’ll find that everything works as you expect with no surprising moving models or weird dimensions and labels.


#9

Thanks @Geo

@20mudlark

If you untick any of the boxes it will be as if you are discarding what you saved before, when you tick it is as if you are saving current view.

You can select a different scene than the current one
by clicking on it. CTRL on Windows will allow you to select multiple scenes.

With scenes selected untick any property and it will discard that property from them. If you tick the property the current displayed property will save on all scenes.