Move and snap not working properly

I’m using Sketchup Pro 2024. I’m trying to move 3D text to the edge on another group (wall) and move and snap to object don’t work. I did the same multiple times in the same sketchup file in other groups and it worked perfectly but now suddenly it doesn’t work in one specific group. The group after that works just fine.
Even the axis lock on vertical (blue) doesn’t work. Green and red axis work fine. Restarting Sketchup didn’t fix the problem.

The file is in the attachment.

Z21 group is the problem.
1.skp (5.5 MB)

What is the problem with that specific group?

It is glued to the face… right click on it and chose Unglue

1 Like

Thanks, that worked.
But how did that happen? Did I accidentally turn it on when making 3D text?

Not accidentally.
It is a basic behaviour of 3D Text tool. It is creating a component whitch is glue to any face, so if you place it to a face (or face of other component/group) that will glue to it. That means you can move that 3D text component along the face plane only.