Snap to Red Axis not working!?

Out of the blue it’s just decided it doesn’t want to know!

The right arrow key is working, and you can see that it turns the snap to axis on and off (red dashed line), but the movement of the object will no snap to the axis.

Absolutely nothing has changed, I’ve been in SketchUp all afternoon. No software updates or anything.
Tried restarting SketchUp, tried restarting my Mac.

Just tried another file and it’s fine, so it’s something in the file that is causing it.

Any ideas?!

Possibly the object has gluing turned on and is glued to a plane perpendicular to red.


You are indeed right, sir!

Although how I turned gluing on for that object, I have no idea as it’s not a command that I use (for better or worse). I guess I have inadvertently hit whatever the keyboard shortcut is.

Thanks for the quick problem solve!

Did you model that object in place on the face it was located on? If so, the component would get the gluing property automatically.

No, it’s a downloaded component, could I have inadvertently glued it the firs time I positioned it?

Downloaded from where? Maybe the author had already given it gluing properties.

3d Warehouse

Enitely possible the author of the component gave it gluing properties when they made it.

1 Like

Could be.

Strange though that I had been moving it around and duplicating it all afternoon without either needing to snap the red axis or noticing it not snapping.

Nevermind though, problem solved and something else learned!

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.