Please help me with moving issues (global axis VS component's axis)?

Hello everyone.

I’m still not getting the moving mechanics in Sketchup. What usually happens is I’ll be 60 or even 80% done with creating something and then just when things are peachy, I’ll try to move a component straight on one of the main global axis choices… and I simply cannot pick the global axis. Is there a way to toggle off the axis of the component so that when I pick the move tool, I’m trying to lock on the global axis? (If I understand my problem correctly).

All of my pieces are components so I believe my problem has something to do with Sketchup thinking I want to move something relative to the components own axis and not the global one? Even pressing “up” right after picking the object which I thought would lock me to the blue axis does not work. My component simply goes flying off the grid in the wrong direction.

Thank you for any help

Part of what you describe sounds like your components have “glue to” enabled. When a component is glued to a plane and you attempt to move the component off that plane, it actually moves in the plane to a point that projects onto the viewport where you have moved the cursor. Try right-click and see whether “unglue” is dark (i.e. not disabled gray) in the context menu.

1 Like

OK, thank you. I never noticed that characteristic… (glue to). I’ll check for that.

Maybe I hit a hot key that turns that one by accident.

Thank you,


This is exactly what happened! Now, is there a possibility that when I create or move a component onto the face of another component… the “glue to” thing is automatically chosen?

Thank you.

When you create a component and one of its faces lies on another existing face, SketchUp turns on the glue-to behavior by default. This feature is somewhat like how it will turn on “replace …” by default if there is unselected geometry touching what you have selected for making the component.

You have an opportunity to override this behavior in the dialog for creating a component, and can also turn it off later by editing the component through the component window.

In addition to what Steve said, if the surface you have drawn the component-to-be on is inside a component or group, the gluing attribute will be set to None by default. It’s only when you are drawing on a loose face/surface that you’ll get that gluing automatically.

In addition the what Steve and Dave said, components don’t magically acquire Gluing properties by touching a surface. They need to be created with Gluing.
3D Lettering is one example of something created with gluing automatically, if you place it on a face it will glue to that one. However if first placed away from a face it not be given gluing properties.

Thank you Gents.

So it sounds like I accidentally hit a “hot key” or “shortcut key” that glued the two components.

Thank you again,


I don’t think there’s any shortcut key to invoke gluing. It sounds more like you made the component on an ungrouped face.

I see. I know I didn’t draw directly on the face of the component. I simply created a 3d text using the text tool, and simply placed it on top of the other component. I’m not 100% sure but I believe when I created the text, I thought I moved it to the face of the other component. But maybe I created the text directly on the face from the beginning and that glued it.

In any rate, It’s very helpful that you guys told me about the “glue to” scenario because I have had this problem many times and always thought I just didn’t understand the component axis.

I really appreciate you guys.

3D text is automatically created with gluing.

1 Like

Ahahah. Mystery solved, thank you Dave!