Mouse wheel button suddenly not working properly

Hi, I am just learning Sketchup. I’ve been working my way through the tutorials at our beach-house, on an old Windows 10 notebook computer. I’ve now come-back home where I’m running on a Windows 11 machine. When I press and hold the wheel button with the shift-key I expect to be able to pan, but instead it zooms, like I am rolling the wheel. I’ve tried a different mouse and keyboard, and uninstalled my Microsoft Keyboard app, and a few other things, to no avail.
It isn’t consistent. Most time, just holding the wheel button down zooms in, but sometimes it zooms AND shows the pan cursor, sometimes it goes straight to pan even though I’m not holding the shift-key.
I’m out of ideas, so I hope someone can help.
Thanks,
Brian

1 Like

Hi,

yeah, SU23 moved to a new framework, QT, for its interface. Turns out QT contains not only up and down screll, but also side scroll.

the vast majority of mice don’t have side scroll, but a handful, including a handful of microsoft ones, do.

you should check this thread (this message and the next cover microsoft)

people are discussing solutions, between updating the drivers, deactivating the sidescroll in a mouse-managing software, to typing a few lines of code.

1 Like

Thanks, that thread was helpful, I’ve got something that works now, but is very difficult to use (I posted details in the other thread). Essentially, by fiddling with mouse settings, it now works provided there is no sideways pressure on the mouse wheel when I click it, which is very difficult for me to do.

1 Like