Mouse selection has 4.53 second lag

Using Make 2017 successfully for 8 months; in habit of leaving SU open all the time; returned to an open drawing and found a “you’ve crashed” message; closed SU, restarted PC, and reopened the drawing; initially thought mouse was unresponsive, but saw that pointer moved freely and could make selections in menu trays; then noticed that when selecting a drawing object it took a long time before the object was highlighted.
Example: opened SU to a new drawing; select the default character image and it takes 4.53 +/- seconds for the image to highlight.
I de-installed Make 2017 and reinstalled Make (now called Desktop?) 2018, but the issue persists.

Lots of threads on this topic already. Easily found with a quick search. Common problem is that an automatic Windows update either change the default graphics adaptor or installs a bad Intel graphics driver. Rolling back the driver usually helps. You should also make sure the your Nvidia card is still set up as the default for SketchUp instead of the Intel HD graphics.

Thanks for the response; this is my first SU Community effort. I did search and found bounty of related threads, however the common fix was a “rollback” of Windows 10 updated Intel graphics driver; how is such a rollback accomplished?

Also, in the de-install/reinstall of SU referenced above, I also reinstalled Nvidia and updated Nvidia drivers; re “make sure the your Nvidia card is still set up as the default for SketchUp”, is that done in SU and if so how?

Rolling back the driver is done in the Control Panel.


You may not have to do that if SketchUp is using the Nvidia card, though. Check that in SketchUp. Window>Preferences>OpenGL.

If you need to change it, right click on an empty part of the desktop and choose the NVIDIA control panel. Go to Manage 3D Settings.

OK, making progress; SketchUp is not using NVIDIA card. When I go to SU Window>Preferences>OpenGL I get:
Vendor: Intel
Renderer: Intel® HD Graphics 530
GL Version 4.5.0 - Build 22.20.16.4771

“OpenGL Details” gives the message:
“SketchUp found the following - SketchUp has detected you are using a “Intel® HD Graphics 530” graphics card when your system is capable of using an AMD or NVIDIA graphics card. SketchUp will likely perform better if you change your system to use the AMD or NVIDIA card.
Updating your graphics card drivers might fix the problem.”

When I right click on an empty part of the desktop and choose the NVIDIA control panel I get a pane titled “NVDA Control Panel” which has an icon of a yellow triangle surrounding an exclamation mark with the message:
“NVIDIA Display settings are not available”
“You are not currently using a display attached to an NVIDIA GPU.”

Sounds to me as if you need to attach the display to the Nvidia card, then. It’s strange to have both AMD and Nvidia cards in the same computer.

How do I attach display to NVIDIA card?
Didn’t/don’t know about AMD card but I installed NVIDIA on stock HP Envy PC.

This is a desktop computer? Generally there would be a display connector on the video card on the back of the computer. I guess I would open the case and look at the video cards if I couldn’t tell by looking at the back.

DaveR (coincidently that is my first name and initial of last name), thank you for your time and effort, they are very much appreciated.
Yes, desktop; and there are potentially two vid cards based on looking at back of tower case. However, as stated, this system ran SU effectively with current physical configuration. Before I crack open the case, I will try and reinstall NVIDIA using NVIDIA install CD.

It did before an automatic Windows update changed the default graphics card to the Intel graphics adaptor. Since Microsoft seems hell-bent on making the Intel adapter the default, you will have to keep pushing back and resetting it. Probably you were using the AMD card before and it might have worked fine although Nvidia has a history of much better OpenGL support. Since you have an Nvidia card, too, it would be a shame not to be using it for SketchUp.

Rolled back Intel drivers and SU select tool appears to work correctly; Yippee!

In Device Manager>Intel® HD Graphics 530 Properties>Driver; I notice option buttons for “Disable Device” and “Uninstall Device”; should I consider one of these and if so, which option?

I’d just leave it alone and make sure your display is connected to the Nvidia card directly.

Will do; thanks again

1 Like

What graphics does SU now say you are using via Window > Preferences > OpenGL > details button?

When you went to Windows’ device manager, did you see an NVidia entry under the display adaptors?

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.