Mouse issues - Orbit & Pan with scroll wheel

Hi RLGL, Thanks for that. It is a new mouse and I went straight to LOGI got the lates drivers and followed all instructions. I was hoping it is a known issue as there seems to be some repeating functionality with this mouse. So far, it works best with the Logi Options uninstalled.

Hi Dave R,

I get a similar result, in that the icon changes to the Pan (hand) but the functionality doesn’t materialise…

Nick

To get orbit to work, i must hold down center mouse wheel AND left click at the same time, and for pan to work i must do the same + holding shift. Do not understand.

That’s not the way SketchUp is setup to work so there’s something with the mouse drivers that is confusing things.

On my Macbook Pro I have never had any issues with plugging in the receiver for a Logitech wireless mouse and getting to work. No settings have been required.

Agreed. Any mouse recommendation? i have now tried 2 MX Anywhere 3 with same issues

I’ve got several M325s and a couple of M510s that all work on my MBP. One of the 510s, my daily driver, has been used so much I’ve worn the feet off and the bottom is polished to a mirror finish and the branding is gone from the top of it. Still works fine. They are much less expensive than the MX Anywhere 3.

1 Like

I had some issues with my MX Master 3 after Logi Options was updates not too long ago and I found a fix online which worked for me:

Open System Preferences

Goto “Accessibility”

Unlock to allow changes

Uncheck both Logi Options and Daemon

Lock to prevent changes

Restart computer

Go back and recheck both Logi options and Daemon

Seems weird but it worked for my mouse.

1 Like

The MX series loads from USB. I hate the waste from alkaline batteries.

I currently have a MX Master 2S for all my computers. The Logitech options driver and control panel has given me no trouble at all. Now I don’t remember if this was the default wheel button setting:
image

For right now, i can deal with the process of holding wheel button down AND left click at same time to orbit, but i cannot get pan to work whatsoever. Is the 2nd middle button, set to gesture > pan the correct setting? i have it set this way and it is doing nothing, not even pulling up the pan hand

I do, too. Rechargeable AAs work fine for me, though. And I don’t have to throw away the whole mouse when the batteries stop taking a charge.

Hello people of Sketchup!

Got the following response from Logitech a few years ago (2015). Maybe it helps next time you buy a mouse.

"As I understand it your MX Anywhere 2 does not work satisfactory in applications such as AutoCad and SketchUp.

I regret to inform you that neither MX Anywhere 2 or Anywhere Mouse MX to be officially supported and developed for programs such the ones mentioned above. None of our current or previous range of models on the regular Logitech website are fully supported or intended for this.

The brand we recommend for programs such as AutoCad and SketchUp is 3Connexion."

(If you have 3Dconnexion products, the new SU pro 2021 might not work properly or unexpected.)

I uninstalled Logi Options, problem solved. MX Anywhere 3 mouse works perfectly with Sketchup Make 2017 without Logi Options. Sadly, you lose all of the tuning of the mouse that Logi Options gives you. Logitech should look into this issue. Using the built in mouse driver on Mac OS Big Sur the mouse works for Orbit and Pan in Sketchup as expected.

Thanks Carl,

ave you (or anyone) tried the 3dConnexion wireless CadMouse? want to be sure it works before committing!

Cheers

I do have a compact version and is perfectly works on Windows. Best mouse I ever have.

I’m not sure if it will work on “Operating System : IOS 10” what you have, but I heard that someone else satisfied using on Mac OS… :wink:

1 Like

Hi.

I got the wired one and it’s awesome + a Space mouse wireless, also awesome with SketchUp. The 3D connexion products I have feels and works like a premium product should.
The 3D connexion support is also good, if something breaks they send a new one without trouble.
(I’m a Windows 10 user)

1 Like

Hi Anssi, I have exactly same mouse as yours and now having the same issue - cannot orbit& pan when holding my scroll wheel, even though it is set as middle button. I’m working in SKP Pro 2021, I wonder if you’re using this SKP version as well or other versions?

No problems noticed here. Have you tried updating the Logitech Options software? Is the MX 2 your only mouse? Does the middle button work in other software? Are you trying to orbit with the scroll wheel stepping off? That is a trick I cannot accomplish so I keep the stepping mode on.

What is the stepping mode? How to do that?

I don’t know if it really is called that. The mouse has the small separate “wheel mode shift” button next to the wheel that controls if the wheel moves “freely” or in steps. I find it hard to press the wheel button when in “freewheeling” mode.