Monochromatic materials not displaying in GE


#1

I have created a model that uses both textured and colored materials. When exported as .kmz, the materials that have no texture and are colored don’t display at all, or display as completely transparent. Thus, half the faces are missing.


#2

Click on Export, then “Options” and check Two sided faces.


#3

There is no such option in the .kmz export options.


Double sided Materials option in Collada Exports from Sketchup not working?
#4

Ah, that’s Collada, which is what gets embedded in a KMZ. I’d guess those simplified export options for KMZ are Google requested for importing to Google Earth.

Here’s what I did: took a simple model, exported 2-sided faces in Collada and named it untitled.dae, and did a regular KMZ export. Unzip the KMZ, and note the models/untitled.dae. Copy your exported Collada to overwrite the models/untitled.dae, and copy your collada-exported material names to models/untitled/ directory. My models/untitled/ directory had 3 jpg’s from my material names and renamed them material.jpg, material_01.jpg and material_2.jpg. I just added the real material names from my collada model. I could remove the material* ones, but I left them. If I had a lot of them, I’d remove.

Now (Mac) select the doc.kml and model/ directory to select both, right click and select “Compress 2 items”. Rename the Archive.zip to Foo.kmz (original name), and… Bob’s your uncle!