[Import] Kmz import failed with Google Earth model

I’m trying to import a kmz file (from Google Earth).
I get an “Import Failed” message. what could be the problem?
I attached the kmz file, which opens fine in Google Earth.
Tomki.kmz (12.4 KB)

I can confirm the opening in Earth and the failure in SketchUp. The file itself is not corrupted, you can rename it to zip and see the XML-structure in it. Sorry, no solution from me here.

And this is SketchUp 2015 latest release ?
Windows or Mac ?
If Windows: 32bit or 64bit ?

I’ve tried with SU2015 Pro, latest release, Win64.

Huck, there’s no model in the KMZ file.
What were you hoping to import?

Perhaps @Aerilius can tell us if his KML Tools plugin works with SU 2015

Regarding no model in the KMZ file. It contains lines and waypoints. In Google Earth you can see these lines (which outline specific areas of a site) on the terrain. One can import the Terrain from Google Earth into SketchUp and then import the KMZ file with these areas and waypoint displayed on the terrain. It is quite useful. I also get GPS waypoints into Google Earth and then into SketchUp this way. You can do all kinds of site plans and designs this way, locate trees, particular view spots, etc.

I’m still getting the error with SKU2015 and latest Google Earth Pro. Exporting a simple polygon for a site as .kmz and still getting import error in SketchUp. Any solutions? (MacOS X 10.10.5)

I have 15 and Google Earth 7.1.5.1557 and I tried it on Mac OS 10.11.2 and it worked, so I don’t think it’s broken. You geo-located your model? Try a few other things, and unzip the kmz to look at the KML… it’s likely something on your machine.

Hello,

I have the same problem : a file that I can open and see with GEarth, (with polygons) but this same file cannot be imported to SU Make 16 (“Import failed”, for .kmz as well as .kml).

Did you find a solution ?

Thank you very much,

Baptiste

Can you upload the file here? Lacking that, we have no way to analyze what you are seeing.

Hey,

Thank you for your interest. Here is the file :

Test_GE_SU.kmz (1,8 Mo)

Baptiste

There is no Collada geometry in that file. Unzip it and look for yourself. SketchUp uses associated models/some-model.dae files, not tags in kml. I think it’s been that way since Google bought Keyhole in 2004 and SketchUp in 2006. You have flat, 2D geometry - SketchUp is 3D.

1 Like

Thank you for your quick answer !

Do you mean that there is no way for me to import this file to SU ?

How could I do to get these field limits into Sketch Up, so I can design according to it ?

Thanks again !

  1. Unzip the kmz - you have one file: doc.kml
  2. Note that the lines you’re interested in are in the tags inside doc.kml
  3. See if a plugin would do it - something like http://sketchucation.com/forums/viewtopic.php?f=323&t=38009 perhaps… that only worked until SketchUp 2013, so ask the experts here what to do, or ask @Aerilius to update the plugin? @Aerilius?

[TOPIC SOLVED]

Hi,

I understood the problem. And decided to solve my original problem with a different approach : I work on QGIS to create a shp (with polylines). Then I use the plugin ShapeImporter to import it to Sketch Up (skipping the kml/kmw step). And it works !

Thank you @Barry and @slbaumgartner for your interest and your help.

Best regards,

Baptiste