Issue Importing into Google Earth


I have exported my model from Sketchup, as a KMZ. It’s a model of a house, with textures.

When I import the KMZ into Google Earth, it does this:

Does anyone know if I’m doing something wrong here?

Many thanks in advance,

0434 613 800

It appears to be on it’s side, and very broken!

It start out looking like this…

Could you share the SKP file for the house?

Yeah no worries - please see attached:

190 Beauchamp Loop v0.3.skp (1.1 MB)



Here’s what I see when I open the KMZ in GE immediately after opening the SKP file.

I’ve tried a variety of things in SketchUp but haven’t got it to fail yet. Did you do anything to the model before uploading it?

Hi Dave,

Thank you for taking the time to have a go at loading my .KMZ file yourself.

Following this, as it appeared to be a GE issue rather than Sketchup issue, I returned to GE. I followed the link to “older versions” of GE, and downloaded the desktop version. Once I imported my KMZ, I got the same result as you did above :slight_smile:

It would seem the “new” Google Earth (here -, isn’t quite ready for KMZ imports.

Thank you again for your help with this; hopefully Google will fix the KMZ import issue in the new GE sometime soon.



1 Like

Interesting. I guess I haven’t updated GE Pro for awhile.

Thanks for the information.

I am having this same issue - .kmz files import properly into the desktop version, but when I try to import into the chrome version, my kmz models are broken in a similar manner that you posted.

Any ideas out there?

Don’t use the Chrome version.

I’ve seen similar reports regarding GE in Chrome. It appears the KMZ import to Chrome is broken or at least not implemented correctly which I can imagine would be a challenge when dealing with the various browsers.

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.