SketchUp Pro to Google Earth Giant Black Blob In Wrong Spot

I’ve been trying to do this for a long time now and I had just given up deciding that it was impossible, but I just came across a document that suggests otherwise. Hopefully someone can tell me what I’m doing wrong.

When I export a very simple geolocated box in SketchUp to KMZ and import it into Google Earth the box gets way bigger and moved locations.

Here’s the file of the box:

Here’s what it looks like when it uploads to Google Earth:

When I try to do the same thing with this model that has more complicated (but still super simple)

It creates this in Google Earth like 100 miles away:

Even when I try to use the KMZ example file listed in the tutorial document, which allegedly produces this:
43%20PM

I end up with this in Google Earth:

I saw on another forum post that someone was able to at least get their model to show up in Google Earth

What am I doing wrong here?

It is possible that something has changed on the GE side of things. As far as I know, we do not export to KMZ file now any differently than we have in the past.

I downloaded your first file. In SketchUp looks like this:

Exported KMZ and open that in GE Pro and get this:

It seems to place the cube correctly in GE Pro as far as I can tell.

Seems like it may be a problem with the web version of GE. Have you tried the desktop Pro version?

Any idea why when I do the exact same thing I get a much larger box in a different location?

I just did it again and recorded my screen while I did it and ended up with he exact same results I had before.

https://drive.google.com/drive/u/0/folders/1j3ou9KBe3tFO1S36hMXRDNpsO9N5TLcf

https://drive.google.com/drive/u/0/folders/1j3ou9KBe3tFO1S36hMXRDNpsO9N5TLcf

As Eric mentioned, it might have something to do with using the web version of Google Earth.

1 Like

sorry just saw your comment Eric. I’ve only been trying it with the web version today. As far as I’m aware the web and desktop versions are supposed to be the same? I’ll try now

Yes one would think but we have to exhaust all possibilities when troubleshooting problems remotely :wink:

1 Like

I think if they were, I’d get the same result on Pro with your model that you were getting in the browser.

1 Like

Welp, looks like that was the issue for the at least part of the problem. I’ll check w the more complicated model now.

2 Likes

Eric-S, do you know if there is anyway to share a map w KMZ files uploaded to it? Maybe the better way to word it is do you know if there is a way to upload the model that I am viewing in Google Earth Desktop version into a space online that is publicly viewable?

Sorry just for the sake of documenting everything, there’s also a really helpful tutorial available, but I don’t think it mentions the need to use only the Desktop version of Google Earth: https://help.sketchup.com/en/sketchup/viewing-your-model-google-earth

I think that was written before the web-based version of Google Earth was released.

I suspect that the web-based version of GE probably changes fairly frequently so who knows? Next week it might work fine.

1 Like

Unfortunately I haven’t come across anything that works seamlessly like you’re describing. As you know, you can share the KMZ file and have someone else open it in GE Pro. Or you can import a much larger or higher res terrain/aerial information plus open source buildings and then upload your model to 3D Warehouse or embed into a custom page for someone to spin around themselves.

See simple test here of what I’m referring to. This was created with open source buildings+terrain with imported Google Earth Aerial and then saved to 3D Warehouse and embedded into my website.

A lot of work I know…but that’s what it takes to maintain quality high and control of the process :confused:

1 Like

I have the same issue from the browser version, both out of scale simple objects and the same creeping blob in the MANY versions I am trying to sort this out.

Uploading: Screen Shot 2019-04-18 at 5.59.25 PM.png…

This looks like the bug with the Collada file reader in Google Earth that was (is?) present in some Google Earth versions.

The symptom was that the model appeared 1.) at a huge scale (and due to this also offset), 2.) skewed/distorted with many sharp-edged shards, 3.) mostly dark towards black shaded triangles.

I don’t remember the resolution, but I would suggest to try whether it helps (on a simple test model first):

  • avoid scale/skew transformations on all groups/components be applying the scale/skew to the definition (right-click → Scale Definition)
  • or explode all groups/components
  • (or a different Collada version, but SketchUp has no choice for that, older SketchUp versions exported a different variant of Collada)
  • (or it may require another version number of the Google Earth application)
1 Like

I was totally on the edge of my seat with this post! The same thing has happened to me and I’ve tried a million different KMZ files, browsers, and both Apple and PC’s to no avail. THey shouldn’t offer the option to upload a KMZ file on the web version of GE if it doesn’t work. I have searched high and low. By now to not have a way to embed tours/buildings from GE to your website seems just crazy.34%20PM

Just a point of clarification… Google Earth is owned and operated by Google… we are Trimble. Google USED to allow us to upload files into their site, but have cut off the service… We agree, it is a bummer that does not work, but there is nothing we (Trimble) can do about it.

2 Likes