Failed to Import KMZ file


#1

I’m having a problem where I can export as a KMZ just fine but when I try to re-import it I get a “Failed to Import” message pop up.
BuildingModel.kmz (133.2 KB)
BuildingModel.skp (1.6 MB)

I’ve included both the KMZ file and the model. It might have to do with hidden geometry or perhaps the cutting components that the plugin FaceCutter produces. When I explode everything it suddenly is able to be exported and then re-imported without fail however that ruins the drawing so that’s not an option.
IT SEEMS to be something to do with hidden geometry although I’m not entirely sure.
Also I am relying on the FaceCutter plugin in order for this to work
I’ve looked at other topics regarding failure to import KMZ files but didn’t find any answer to solve the problem I’m having.

EDIT: I’m currently on Sketchup 2016


#2

KMZ is a zip file of a Collada model and some location data. If I try the embedded DAE file it also fails.

The XML in the Collada file looks ok. The only thing that seems wrong is that you have a lot of faces reverse in the model. Try viewing the SKP with View/Faces set to Monochrome.

I don’t think that should stop the KMZ from working, but if I try an export and an import, it fails for me too.


#3

Yeah, I tried importing/exporting to/from DAE as well and it said I was missing some textures. I’m sure the faces are all wrong though. Thanks for helping me dig into it. I’ll try replacing the textures and see if it still fails.


#4

turn on edges and try exporting…

john


#5

Oh man… I hope that’s not the issue or else I’ll be embarassed haha.


#6

Didn’t seem to fix my issue.


#7

it was just a thought, but it does make it easier to fix the model…

FaceCutter should have an option to ‘make good’ all it’s tricks…

john


#8

Missing textures: Collada creates a directory with the materials, at the same level of the .dae (xml file). So if I export untitled.dae, the materials are exported as untitled/foo.jpg, etc…


#9

So are you saying that the missing textures are likely the issue causing it to fail to import?


#10

the 5.9MB [expanded] of unused materials are possibly not helping, export or import…

john


#11

Yeah, probably not. I wonder if I got rid of the unused materials if it’d fix the problem. I’m guessing not but I’ll try it out and see.


#12

I’m having trouble on my machine, others here aren’t: I’ll troubleshoot for a bit.

Edit: I wasn’t exporting edges. Yours worked when I exported edges, too. The materials appeared to import (looking at rooster / wind vane).


#13

Huh? Really? That’s odd. I tried that and it still wasn’t working for me.


#14

Did you export to a KMZ file?

Also what options did you use?


#15

I imported Collada.


#16

When I tried to export to kmz in Sketchup 2017 I got an error message:
Results of Validity Check.
*** Problems were found that could not be fixed! ***

The entity at address 4d3320 has an invalid id (0) destroyed (0)


#17

Oooh, that’s a very good insight. Thank you. I wonder why it’s trying to export something that has been deleted.


#18

I may have tried to ‘fix’ it during the export :slight_smile:


#19

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.