Model Suddenly Freezing

I have been enjoying the trial of SketchUp Pro, and was considering buying in, but now -suddenly - it freezes every time I click something with any tool, including just select. It hangs for about 2 minutes each time. I also cannot purge - the system freezes entirely. This stared happening suddenly with a model I’ve been using for a couple of weeks with no changes to the model itself - Saturday night, everything ran perfectly, Sunday night it was suddenly unusable.

My graphics card is more than sufficient, I have ensured it’s being used, drivers are updated, and I’ve reinstalled both the drivers and Sketchup itself, and it’s only affecting this one model it seems. (Though it’s the only large model I’m using.) It has nothing to do with how much is on screen either - I have hidden nearly the entire model and it still happens.

Suggestions welcome - I need this model and want to continue using SketchUp.

When you installed SketchUp, did you do so correctly? That is, did you right click on the downloaded installer file and choose Run as administrator from the Context menu?

How large is the file?

I believe I did, but it’s easy enough to do so again to be sure.

The model is only 186 MB

When you try it, choose the repair option.

186 Mb is getting to be a pretty large file so it wouldn’t surprise me that it stalls periodically. Especially when auto-saving or if there’s complex geometry or large texture files.


Yeah, occasional stalls would make some sense. But it went from running flawlessly to stalling for minutes at a time with every single click. I am going to fiddle with the install presently.

I did a completely fresh install, the model loads flawlessly, I can camera around all and as quickly as I like without a hitch. The moment I select something, it goes frozen.

Try going to Window>Model Info>Statistics>Purge Unused and see if you can clean up the model some. Might require some patience.

I tried this twice last night and let it run for hours. I will try it again on this install, though.

Did you download a bunch of components from the 3D Warehouse?

You might try purging individual things like components, materials, and styles. Each of the inspector panels has a right-pointing arrow icon on the right side that opens a Details menu. If Purge is not grayed out, click on it. Purge unused components before materials.

1 Like

I don’t seem to have an option to Purge from the Details arrow menu at all.

In the interim, I have tried the main “Purge Unused” twice to just have it lock up immediately and completely both times.

You must be in ‘In Model’ for that to be available. Click the little house icon.

Aha… the operation, at least, seemed to have worked - and lord I had no idea it kept things I didn’t even add to the model.

For grins I loaded it into the web version, and it actually runs fine - with some lag - but no freezing. I’ll see about purging everything and where I end up.

Okay, purging has been accomplished. Sadly, no change to the freeze behavior.

It’s very hard to say much more without looking at the model itself, I don’t want to download such a large model myself but could you post a couple of screen shots.

What screenshots would be useful?

A general view with some things selected, to start with, just to get some idea of what we are looking at. It may be obvious but without seeing anything it’s all a bit vague.

This is the model with the majority of things hidden, which is how I have been working with it.

So many questions.
Are you using and understanding groups and components?
Are you using Tags and again are you using them correctly, as in only on groups or components?
How are you hiding things and what are they?

How many faces and edges are there in the model?
Window/Model Info/ Statistics tick box for show nested.

Does the freezing stop if you turn off edges and profiles?
View/Edge Style/ untic edges and profiles.

I know you mentioned it originally but check Window/Preferences/OpenGl/ Graphic card details. Make sure it is the Nvidia.

This is the model with everything loaded. On the web, it chugs but everything runs. On my desktop, I can load and pan flawlessly, but the moment I use a tool, including select, it freezes instantly.