Sketchup 2021 freezes

Hi, I’m using sketchup pro 2021 but when I start to do my project it starts to freez every 10 minutes. My system is i7 10th gen RTX2070 super 16 gb ram laptop. I try to change settings tto only nvidia RTX2070 on graphic card contol panel nothing changed. I try update the driver. I try repair on skechup exe. Then ı download checkup it gaves
Error: Something went wrong while retrieving the system information from your computer. This may cause tests regarding System RAM, Windows version and/or graphics card memory to fail.
Error: Graphics card information is missing.
these errors. Can any one help me?

Hello,
your freezes might happen when sketchup autosaves. Autosaves are set to occur every 5 minutes by default. How big is the model you are working on ? if it is 200 mb or more, it can become annoying, especially if the model is saved on a network with slower transfer speeds than a local ssd.

it is 136 mb but I use nvme sssd

Do you sometimes purge you model ?
If you do, and i’m not advising it for long term, can you try disabling autosaves (go to window > preferences > general and uncheck autosave) see if the problem comes from that ?

okay I will try .Is making autosave time 30 minute be a solution?

The best solution would be to reduce your model size, if possible : by using smaller textures, import less 3d models from 3D warehouse or choose them wisely.
Then you can adjust the autosave time according to the best balance between risk and productivity

But first, just disactivate for a while to make sure it comes from that ! it might be something else.

Okay I try them but what about the errors that checkup gave

I get the same errors with the check-up and everything is working fine.
Just make sure your graphic card is recognized & currently in use (window > preferences > openGL > graphic card details). Since you’re on a laptop, a switch is possible between integrated chipset and dedicated card for energy saving matter

ı chack that and make it RTX2070 super only

Everything fine then

Before you do anything with your model, go to Window>Model Info>Statistics and click Purge Unused.

okey if it still freez I will write agein soon

After you purge unused stuff from the model how large is the file?

wow 10 mb only

it was one of the first questions asked :wink:

1 Like

Probably won’t take very long to autosave at all now.

Keep your models clean and you won’t have the problems.

thanks very much both of you I wish it never repeats agein.

1 Like

Keep your models clean and you won’t have repeats.