Model freezes when trying to import from 3D Warehouse

Hi there,

I am hoping someone can help me as I haven’t gotten far with a sketchup rep.

I have been using sketchup for many years with no problems. I recently downloaded sketchup Pro 2019 and every time I try to import something from 3D warehouse, my model freezes. I have tried importing an item on a fresh model with nothing in there along with many tries on different models. Still, any time I try to import something from Warehouse, it freezes. I still have the older version and it still works perfectly. I’m sort of screwed right now because I have started working in Pro and once you do, you can’t revert back to an old/free version with those models.

Also, I have plenty of space on my mac so storage isn’t an issue.

Hope I can find a solution here.

Thanks!

how did you install SU?

did you drag the SU icon onto the Applications folder icon after double clicking the download…

john

Hi John,

Yes, I dragged the icon into applications. Just downloaded directly from the sketchup site.

does it look like this in Finder…

59%20am

do all three open?

john

You can save models in older formats and open them in other (older) program versions.

1 Like

Animation for Cotty’s solution:

1 Like

Yes all 3 open

When you say import from 3D Warehouse, do you mean directly importing the model from the 3D Warehouse window inside of SketchUp, or do you mean any model downloaded previously from 3D Warehouse in a browser?

Do any of your own models import ok?

If it only freezes when importing from within the 3D Warehouse window inside SketchUp, it would be worth quitting SketchUp and deleting the WebCache folder from inside here:

~/Library/Application Support/SketchUp 2019/

When you open SketchUp again that folder will are recreated, and if there were any corrupt files causing the 3D Warehouse window to fail, that should fix it.

Hi Colin,

When I try to directly import the model from 3D warehouse.

I don’t have any of my own models I import (I assume you mean component models?)

Yes, only freezes when importing from within the 3D warehouse window. Where would I find the library to delete the WebCache folder. This is my whole SketchUp 2019 folder:

On Mac, in Finder, there is a Go menu. In there is Go to Folder. Open that, and paste in the text I gave:

~/Library/Application Support/SketchUp 2019/

Wow!!! That totally worked. Thank you so so so much Colin!

Happy to hear that. Hopefully it will work for the other person having the issue.