Model disappers after not using Sketchup program

I use latest version of Sketchup Make with Windows 10, I leave on Sketchup and other programs open most of the time and use the Windows 10 sleep mode in the evening, it seems that every time I leave a model open and leave the computer for some time when I return the model is gone I try pressing escape key, space bar nothing works. At first I thought this was occurring after return from sleep mode but that is not the case, I can leave the computer for a few hours and when I return the model is gone.
I would appreciate any ideas, I have been trying to be careful about saving my work but this situation has created problems with loosing work so it is kind of frustrating.

Thanks

Have you saved the model before leaving the computer? Is it possible your computer is rebooting while you are gone and Windows is just reopening the programs that were open at the time it rebooted?

I like the reboot idea.

If that doesn’t turn out to be the issue here, then I think we need to know a little more about what your computer setup is… and specifically how your hard drive (or drives) are utilized…

Are you running a raid configuration for instance?..Are files being stored directly onto your internal drive?.. or are you connected to a network?

Thanks for your reply’s,
I am not 100% sure but I am thinking that I was not having this problem until I upgraded to the current version 16, do you happen to know if I can go back to the prior version? Since this problem started I am attempting to save my work whenever I will be leaving the computer, so when I return to the computer and I am looking at a blank white sketchup page and cannot retrieve the model I shut down sketchup, restart sketchup and reload the drawing. Yesterday I lost the model once, today I have Sketch up open with a model open and it has not vanished,

Regarding rebooting, for the most part I always have multiple applications open all the time and if this were being caused by reboots I would notice as all the other programs would have to be restarted, this is not the case.

Regarding my computer I have i7 processor, 24 gig ram, the program is running from my internal hard drive and the sketchup files are stored on the same internal hard drive.

Hi,

The URL to previous versions of SketchUp is: www.sketchup.com/download/all


Just some Ideas:

This is the first time I’ve seen this issue reported on the forum. Which is odd because I’d expect to see others commenting if it was a unique problem associated with SketchUP 2016 and Windows 10. It’s been out long enough now, and I’m sure more than a few SU users are running under Win 10.

Running multiple applications simultaneously doesn’t create the textbook environment for isolating a problem. If you do have some days in which SketchUp doesn’t drop models, then I wonder how that might coincide with other application NOT being run at that same time.

For the sake of easing up on some of the variables involved, and isolating the problem—to say nothing of the unfortunate consequences of increasing your own aggravation and inconvenience while doing so—I really think you should try to run sketchUp solo for a while… see what happens, and then slowly introduce other programs back into the mix.

The lack of this problem being reported by others, makes it just as likely that you could be encountering incompatibility across applications. Unique to your own computer, and work habits.

AND, Maybe it is SketchUp 2016,… but then there are also all the Extensions which come with it. . . and I wouldn’t rule out the possibility of an outdated extension causing issues as well (if we’re going to entertain this idea of application incompatibility). . . So you might also turn off the plug-ins for a while, or see if you can verify that they have been updated to work with SU 2016.



Software issues aside, this could also have a hardware aspect to it… (albeit a little less likely by comparison, but still worth consideration as a possibility)

You have a lot of memory. Running applications, and the data they generate, get stored there until being written to a drive… I wonder how likely it is that once you load up the memory enough, data finally reaches a bad/weak sector and read/write errors start to occur.

Intermittent memory errors are hard to recognize. But they do happen—I ran across this myself when building a new desktop some time back… While trying to install the OS, and software, I had a random assortment of strange things happening, and not typically repeating themselves when retrying the same task a 2nd time around. There was also a good deal of misdirection, because very often it would seem as if the issue was with my DVD drive not reading the disc correctly. It took a number of days before I finally started to test the memory, and ultimately discovered that my brand new memory straight out of the box was the problem all along.

Checking the memory is relatively easy to do. There are probably a few programs to choose from—but the one that I know of, used, and have no problem recommending is called… MemTest86.

  • [ The reputation of this program has been, and continues to be good, but I haven’t used it lately, so please make sure to check it’s compatible with your computer before jumping into it, if you even do. ]

Intermittent memory errors can be trigged by stress (only occurring after the memory has worked to a certain performance level), or even just encountered once a certain temperature is reached.



… and back into the software realm… you can’t go far wrong by checking over all of your device drivers, looking for update possibilities.

I’d try turning off Autosave.
It may be that SU is crashing when idle and autosave kick in.
Check your Graphic Driver for an update, AMD are known to have some problems with SU.
Try running without Hardware acceleration turned on in the OpenGl settings.

It could be a problem of the Graphic card being on the edge of compatibility and when the autosave kicks in it fails. I don’t remember if you said so or not, but is this Win10 preinstalled or an Update?

1 Like

I think that hibernating computers and OpenGL applications don’t play well together. Hibernating seems to crash OpenGL. I have seen this in other apps beside SketchUp too.

Anssi

I just updated my sketchup pro for the 2018 and was working today in my first project into this version.
Worked for about 5 hours in a file around 60MB.
It disappeared completely from the computer when I left for a dinner. I checked it in the preferences and is programmed for autosave every 5 min. Looked all over the computer and I could’t find it. *SKB *SKP even all the 2018 sketchup projects. To sad.

Had you ever saved the file? Or did you work for five hours without manually saving it all?

What did the statistics show about the file? How many edges and faces were in it? Did the In Model components collection show any components?

Was SketchUp installed correctly? What operating system are you working with? Your profile information is useless regarding operating system. Please update your profile.