Model Disappears During Orbit

orbit
camera
#1

No idea what happened, but I’ve been working on a model and all of the sudden it seems disappear when I orbit the camera. Far as I know I didn’t make any changes. I’ve read some other forum posts on this issue and it seems that the problem is related to “clipping”, but none of the recommendations in the posts worked for me.

Here’s an example of the problem:

Here’s the model itself:

Zoom extents, changing the camera mode, switching between fixed views, etc. I tried selecting all, zooming out, then deselecting just the items in view, and hitting delete as well.

One solution that seems to work is just selecting the model and copy/pasting it into a new file, but I guess I’m still curious to know what happened in the first place.

Any idea what’s going on here?

0 Likes

#2

Probably a leader text entity tied to something you deleted went off to infinity. It’s a known bug. Go to Outliner, select all of the components and groups. Hit Edit>Copy. Then open a new SketchUp model and choose Edit>Paste in place. See if that helps.

2 Likes

#3

Yeah, that’s what I had done to get around it. I updated the original post to reflect it, but was just strange so I wanted to ask. Thank you for confirming that I’m not crazy (at least in this instance)! lol

0 Likes

#4

I didn’t mean to imply that! :smiley:

You could avoid the issue if you delete leader text entities before deleting the component or group it’s pointing at. Or better, save the labeling for LayOut.

1 Like

#5

It’s been discussed several times, but for the benefit of those who might be reading this topic: There is a known bug in SketchUp through 2018 in which if you have attached Leader Text (this tool: 07%20AM ) to a face and subsequently delete that face, the text may fly off to infinity. Model content at infinity causes the view camera to do strange things, usually zooming out so far that the model appears to vanish. In your case you are lucky that orbiting back seems to restore the camera. Often there is nothing you can do that gets back. The copy-paste technique works (so long as your selection doesn’t include the bad text) because it forces SketchUp to generate a new camera in the destination model.

The safe workarounds are to not use leader text until you are finished editing the model, or to use LayOut for labeling (as @DaveR already noted).

1 Like