Model disappears when orbiting

I have a problem with orbiting the camera around my model created in SU Pro 2017. As you can see in the attached video, everything: model, axes, sky - disappears whenever I try to look from the opposite side (both in perspective and parallel projection). The same thing happens when I save the model in 2016 format and open it in in SU Make 2016. The problem occurs in a few particular models but in Statistics no problems are found.

Orbit problem

I believe this can happen if the origin is a long way from the model. Close the component, then Select it, then m for Move, pick the corner of the component at its own internal origin, then type [0,0,0] to move that corner to SU’s origin. Don’t click on the Measurement box, just type instead of clicking the mouse for the Move target.

The video is a little blurry, but it looks as if you have the model component open for editing, with the component’s internal axes and origin visible, but it doesn’t show the model origin or axes. Can you see the axes when the component is closed for editing?

PS. if that doesn’t work, share the model via Dropbox, the 3D warehouse, or another file sharing site like Google Drive and someone can have a look at it.

I modified the model a bit - now the component’s origin perflectly matches SU origin so I can see all the necessary axes. I also scaled down the model cuz it was really huge. But the problem still remains. Can you tell me if it also happens at your computer?
When I saved the model as SU 16 and opened it in SU 16, the camera got completely crazy…

The model from the first link misbehaves badly for me when orbiting or zooming. When it opens, I see an array of rectangular contours, with some non-rectangular objects as well, all apparently on a 2D plane, or nearly so.

I briefly caught a glimpse of some text as I zoomed in or out.

I’m guessing at one possibility is that some Label text has got detached from the item it was attached to, and ‘gone rogue’ (it has happened to me, and there are other posts on this forum about it). But I can’t find it. Nothing shows when I choose Model Info, Text, Select All. Even when I exploded everything, and turn all layers on, I can’t find any using Select All Leader Text, Select All Screen Text, or (in Dimensions) Select All Dimensions.

I tried a window select of everything visible, cut it, and pasted into a new model. It still misbehaves - perhaps the rogue text, if there is some, is included in a sub-group. After some zooming and orbiting, the model consistently jumps to a top down view, with just the top left quadrant around the origin showing a small corner (a few mm square) of what appears to be a reversed face showing from an unnamed group which is parent to a lot of other unnamed groups.

With Outliner set to Expand All, if I click on Zoom Selection for that group, I get to see the whole, also in top down view.

But if I Zoom Extents, I get back to the top down view of a small blue-gray quadrant.

When I tried Fix Problems at this point, I got a very long string of errors which includes multiple instances of vertices and edges with duplicated persistent IDs.

But when I reload the file, and try Fix Problems again, it says the aren’t any problems.

PS. There’s also the component Chris somewhere in the model, but you may have shrunk him to the point where he is invisible. I deleted him via Outliner but that makes no difference.

After I get the plan view of a tiny corner of one group, and zoom out slowly, I got to see some apparently unattacehd text again, and managed to select it (it is nested in a group) and progressively deleted it. But that still doesn’t stop the weird behaviour.

There’s something weirdly corrupted in the file. Sorry, I can’t help you further - I’m well out of my depth here.

Where did the file come from?

I have the same problem. When I orbit or just move, half the walls disappear. It is just imossible to position the camera. It started only a few days ago and it is the same on all my files. I wonder if I have clicked on something by mistake.
If you find a solution to your problem please let me know.

@Flopit, from your description it sounds like you are experiencing clipping. Upload your model so we can see it and help you sort it out.

It definitely isn’t clipping in michal.peczak’s model - much odder, and more or less consistent with unattached text in a (nearly, or maybe completely) 2D model. The text is buried somewhere inside a group, if that is the problem. And all the groups are unnamed, which makes it harder to see where you are when you open anything for editing.

@DaveR I think my problem was clipping. I have made some research after you mentioned it and it seems ok now. So far so good.
Thank you so much, it had been driven crazy for days :))))

Yes. I saw that. I checked the dimensions of some of the groups and they have one dimension shown as “inf”.

@Flopit, glad you got yours sorted.

I didn’t think to check with the Dimension tool. How does it get to have an “inf” dimension, and is it fixable? I’ve never seen that. Does it show the same dimension of “inf” using the Tape Measure tool?

I expect it got that way due to bad scaling of the groups. If you right click on some of them, you’ll see that Reset Scale is available.

I don’t think the tape will show that.

John, I made the model by myself, it wasn’t imported.
DaveR, how did you encounter “inf” dimension? Did you use dimension tool? This sounds exotic to me :stuck_out_tongue:
Resetting Scale doesn’t help either.

1 Like

I used Get Dimensions by Jim Foltz. It shows the bounding box dimensions of a selected group or component.

Here’s an example of the height showing as ~inf.

Some of the groups inside the large group show the same infinite height.

Those numbers are leader text and they didn’t scale properly when you scaled the model down. And Chris has been scaled down so much he’s 0.000 m tall!

It looks to me like this model started life in some other program and was imported to SketchUp at the wrong scale. There’s so much wrong with this one, I think you’d be better off abandoning it and starting with a fresh import at the correct scale.


Ok, thanks a lot for hints! I didn’t expect anyone would examine the problem so carefully!

I had a quick look, I think one of your groups is freaking it out, I suspect its been imported from 2D AutoCad and inadvertently you have a 3D block which I know from bitter experience sends SketchUp wild. Click on your groups one by one and as they are highlighted on the model, change their name to something more meaningful so you have every group/component properly labelled (as per it should be). I think you will find one of your groups, you will click on and not see anything. Get rid of all these, resave, reload and see what happens

I come late into this topic because I was on vacation away from my computer for a while. Your file contained several Text entities whose leader data had gone singular. We’ve seen this bug in several other models recently but nobody has yet determined the exact trigger. I deleted those texts and now have no trouble orbiting or zooming your model. I did a zoom-extents on each scene and then updated them so that the camera won’t jump back as in your originals. Here’s the result:

huby hipso (1.1 MB)

Edit: you also have some texts that I presume were being used to label the regions in your model but have become absurdly large compared to the regions. I reduced them in size, and then they look like this:

Wow! Much appreciation. Thank you!

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.