Model disappeared after changing camera view

#1

Hi all, thanks for the help in advance.

I tried to set my camera view to ‘Front’ and my model suddenly disappeared. Using Zoom Extents didn’t bring it back into view. After repeatedly zooming and panning around, I was able to locate the raster image that I had built on top of, but the model itself seems to have vanished entirely?

I’m concerned that it’s all been deleted out somehow. Is there a way to return to a former save file? Or is my model still there, and I’m just not able to find it?

I tried to upload the file, but was told it was too big. I’ll see if there’s another way and reply to this thread if I can find one. Thanks in advance!

#2

@solastalgia

Possible Causes/Diagnosis:

  1. If a piece of geometry is located extremely far from the origin relative to other geometry, this can mess with SketchUp’s camera display. This can happen when importing various types CAD files or IFC files. … Is your project based on any kind of CAD import?

  2. There is a bug that causes text-leader objects to jump to extreme distances as well. This can cause the same problem. … Does your project include any text-leaders?

Fixes:

  1. One workaround is to do a window selection around the image and the area where you believe the project model to be. After the selection, Edit>Copy (Ctrl C, Command C). Open a new file and either Edit > Paste (Ctrl V / Command V) or Edit > Paste-in-place . This will paste your essential project geometry and image into a new file without the inclusion of the “bad” geometry

  2. Window select outside the project boundry area… essentially selecting geometry far from the project area and then deleting them. This can correct the camera issue but you would be deleting geometry

If you need help, yes, please provide a link to your skp file so we can download and help diagnose the issue.

CD

#3

Try ‘edit-unhide all’ and 'view-hidden geometry. Also check the layers panel in case it is on a hidden layer.
Check the file size too, if it is still the same, the geometry should be there somewhere!

#4

Put the file on something like Dropbox , Google Drive…Post a link on the forum, then someone could look at it.

#5

Better yet, look at Model Info->Statistics. If you see the expected number of edges, faces, components, etc. the content is still there, just not visible.

There are various things that could make model contents seem to vanish and zoom-extents to fail. Until we can take a look at the model, it’s hard to be sure what is wrong.

#6

I had a model to fix the other day, and used the steps that Chris said to do. But then later I thought of a better way. The main drawback of the copy/paste into a new file is that you lose the work you may have put into making scenes. The steps that occurred to me later were (but first do Kenny’s unhide all suggestion):

  1. Top view, zoom in or out until you see everything that you want to keep.
  2. Select tool drag around that part of the model.
  3. Edit/Cut.
  4. Select All, delete.
  5. Edit/Paste in Place.

As an alternative to the select all delete, you could do a zoom extents at that point, just out of curiosity about what the bit of rogue geometry was.

Of course, it could be that the bad geometry was way below ground, and the top down select approach might include it. If that happens just use a side view.