Model area more bright than usual

i just re-installed my sketchup pro 2016 to my new device. But i realized that the model area’s view is a bit brighter than before (makes my eyes sores a lot). thankfully, after i exported the model (into 2D), the view is back to normal brightness. Is there a way to fix this?

i’ve tried changing to other styles and changing the shading settings, but no difference. But when I navigate the model, the model view reverts back to normal brightness and then quickly brighten up again.

You can change the color of the background, choose some darker colors and update the style. This is silly but you can also reduce the brightness of your screen.

not only the brightness, but the color contrast of the model area is annoying. Materials that are supposed to look dark is brighten up. That’s why changing only the background and the desktop brightness is not an option for me.

I’ve been using skp 2016 for 4 years and never had this issue before

What ‘device’ was changed? The monitor or the PC?
You might have use a different color profile on the older device.


not exactly changing device, but I reset my PC

Check the shadows settings. I sometimes use it to alter the brightness of a scene.

1 Like

it works. but then the view brighten up again after a sec. But well, it doesn’t affect my workflow that much, so i’ll wait for the solution patiently.

What we are looking at appears to be a change in SketcUp’s display settings.

Change these under Styles > Edit > Sky/Ground. Also try the antialiating settings under Preferences > Open GL, and also under Shadows. I’m guessing your orgiianl sketchup template had been modified slightly with some differnet colours - it’s also possible that the tempalte originated from an earlier version of SketchUp when the colours may have been different. I wonder what they are like now in SketchUp Pro 2022?

If you are openining the same SKP file from your earlier screenshot, adn the colour appears differently, then we would know that it’s down to your graphics/display or monitor settings which ave changed since your reset.

For SketchUp background settings…the default settings are okay but I personally like a lighter colour ground, and a richer blue but also brighter sky colour. Try to be unique…not everyone needs the exact same Sketchup view of the world!

  • If you live in the Mediterranean them make the ground a light pale gray and the sky a rich deep blue.
  • If you live in the mountains then make the sky a pale blue and the ground a deep brownish grey.

For your PC settings check your display properties settings panel. You may find settings for your graphics card that can adjust the overall image balance and tone.
Look for things like “Emphasis Quality” or “Emphasise performance” or other settings that could affect colour. Display drivers also affect the colour balance of what you see on the screen - if you are going from very old drivers to current drivers, then they may be a slight change.

Monitor settings (selectable from buttons on the screen, but also sometimes from a Control Panel app) will dramatically affect colour balance…even a small change here will affect the tone of an image on screen.

Sometimes apps adjust the colour for what you see on the monitor - i have an app that makes all colours “warmer” in the evening / night time, to reduce eye strain. Obviously this affects colour.

You might want to check in your GPU’s video settings - it can be possible to brighten certain types of content there. That looks like the export image has a different gamma correction applied to what is going on inside of Sketchup
It may be that a graphics driver update has changed something.

I’ve opened the OpenGL settings, and these shows up

there is an anti-aliasing settings, but I can’t change those (is this the default setup from sketchup? I never touched this settings before)

Related to display settings, my PC used to flicker randomly, to the point that the screen went blank. it was fixed just by doing software reset and LCD testing at official Acer service nearby. Later, I updated my OS to windows 11, and the screen-flickering starts again, and fixed with the same method before. so I’m afraid to change those settings.

Try selecting some other antialiasing mode, the one you have seems to have a different color profile than the others. If SketchUp doesn’t let you change that, go to the Nvidia control panel 3D application settings and check that Antialiasing is set to “Application controlled” or equivalent.

1 Like

thank you so much. The method works and everything looks normal now.

I choose the ones with “true color” and 0x anti-aliasing (for operational smoothness)
The one that make that weird color before was an option with “64-bit color”. But after I choose the other, that option dissapeared.