Missing Models


Last year I created 2 models on Sketchup Free. I just now tried to login to Sketchup/Trimble to access the models and was prompted to enter Username/Password (my browser for some reason forgot my login info)… I dont remember which account I signed up with… I use several email addresses and tried them all with no luck - I cannot find my models (hours of work).
The only lead I have is a Share Link to one of the 2 models… so the models are still somewhere in the cloud.

Can anyone pls help me find my files?

Thank you,

You have a Free entitlement with the Gmail address you use in the forum. That one has been going since August 2018.

Pls excuse my ignorance but how do I use my Free Entitlement to find my files?
Maybe I wasnt clear enough - I managed to log in, I even managed to log in with 2 email addresses - but cannot find my files.
The only way I could find to access saved files is to start a new sketch and then click on File → Open… but there are zero files there for me to open.

Here’s a thing you might wanna try. Since you don’t see your model but the share link still works, it should be there, somewhere:

Open a new tab and head for connect.trimble.com and be sure to sign in with the same email address. Then check the North America Pod to see the project called ‘SketchUp’ Check the data explorer or the activities to see what happened to your files. One can even restore (accidentally) removed files from here.


That takes me to the same sad empty Sketchup Folder ;-/

I have a similar problem with Sketchup Free. Some of my older models are gone. My newest model is still available, but work from ~ 2 yrs ago disappeared. I can’t find it in Trimble connect. Is there an auto-delete function in Sketchup Free?

No there is not.

Most often when users can’t find their Sketchup model files it’s because they’ve used a different login account. Also make sure you aren’t just looking at Recent Files.

Screenshot - 7_31_2023 , 11_29_21 AM

Screenshot - 7_31_2023 , 11_29_38 AM

Thanks for the tip. I did have to change my login info recently. I tried my old login credentials but was unsuccessful. Is there any other way to get them back? Fingers crossed!

Well, at least you know now why you’re not seeing the older models. As far as Trimble Connect is concerned you’re a different person with that new login info.

I don’t know if there’s something @colin or someone else can do. I wouldn’t hold my breath, though.

I checked for your name, which isn’t a common one. I only see two accounts, neither of which use the email address you use in the forum.

One started last November, and includes ‘gink’ in the email. The other is your full name at gmail.com. That one started in June 2020.

If either or both of those seem familiar, try signing in with them

1 Like

Success! Thank you @DaveR and @colin!
I used the older email address. Interestingly, I couldn’t find my old files in Trimble Connect. They were just in the homepage when I opened Sketchup Free. Either way, thank you for the help. It’s good to know that I can still access/use those files.

I am having the same problem. I added several models (which I was in the middle of designing) over the last couple of days and when I tried to access them today they were not showing up. I have made sure i was using Trimble connect to look for them. The only model that is showing up is the one I saved today.


There are quite a few SketchUp users with the same name as you, so I can’t easily tell if you have another email address that you have used before. Are there any email addresses you use that might have been used when signing in today? The account I can find has been going since May 2019, and I would expect you to see a lot of models in that one.

is that a btinternet email?

issue solved.

Yes, I checked the email you use in the forum.

How did you solve it?

This topic was automatically closed after 91 days. New replies are no longer allowed.