Missing components in Layout

Hi everyone,

I can’t understand why some of my components in my sketchup model (table, chairs, …) aren’t showing in Layout. I have saved my sketchup model and updated my layout model but that doesn’t fix the problem…
Any thought?
Many thanks


The top image looks like SU, the bottom one like LO.

There are other things that are not reproduced, like the colours of the plants. That suggests to me that the scene imported into LO is different from the one being shown in SU.

Have you updated the scene in SU and then saved the file, and then updated in LO? If not, the problem could be in there somewhere.

Hi Simon,

Yes I have updated the scene in SU, saved the file, and updated it in LO.
Here is the layout file

Uploading: Project6_MasterPlan_KLC.layout…

It doesn’t load completely…

Here is the dropbox link to access the two files:

okay I have uploaded them in dropbox, just shared a link below, hopefully you can access it (first time I’ve done it!)

You have ‘overruled’ some properties of the SketchUp Viewport, they show up darker grey. These are kept and saved in the LayOut Document.
Upon opening, you should get a message to update the document. You can show the inspector (Document set up > references) to check the status. It should be set to ‘Current’ and not ‘Old’

Thanks for your advice, Im going to try that and I’ll let you know if it worked!

I see that the scene in your attached SketchUp model was not updated to reflect the changes you show in your screen shot. You need to update the scene after you make those changes. Also, if you turn off Sky in your style the Background check box in the Styles section of the SketchUp Model panel in LO will work.

I note incorrect tag usage in SketchUp. This can cause you problems.

And it wouldn’t hurt to purge unused stuff from your model once in awhile. I purged your file which reduced the file size by nearly 63%.
Screenshot - 11_20_2021 , 7_00_23 AM

I have opened Layout, updated the out of date document in the pop up window, saved everything, closed Layout, opened it again … but the elements (chairs, table…) were still missing.

Am I doing something wrong?

I copied below a screenshot of the document set up pop up window that appeared when I first opened Layout, and another screenshot of the same thing after I updated the document.


I turned on the tags for the furniture pieces that show in your first screen shot and I updated the scene. I also turned off Sky in the style and updated that.Then I saved the file and updated the reference in LayOut. This is what I see.

Thanks for your reply. I was trying to follow your advice but as I tried to open Sketchup, I had the following message (see screenshot below).
Any idea what’s happening?

Generaally that means you already have the file open.

Here’s the LO file after I made the changes. I also fixed some of your labels so they won’t get cropped during printing and I added some layers to the LO project. Best to separate content based on what it is. The viewport is still on the Default layer.

Thank you very much that is SO helpful!! I still have a lot to learn with Sketchup and Layout… (did get some training though!).
You were absolutely right about the scene no been updated. That fixed the problem as soon as I tried it.
For the new Layout file you sent me, can I simply replace it with my old Layout file? That won’t mess up the link between sketchup and Layout?

By the way do you offer any one to one Skechup training? I would LOVE to get the opportunity to go over this Sketchup model you just saw with someone who really knows his stuff to show me what Im doing wrong and how I could improve.

If you want to use my revision of your files, you can simply save my file with over yours. (I appended my initials to it when I saved it but you can remove them. If you want to use the SketchUp file I purged, right click on the viewport in LayOut and choose Open with SketchUp. Then do File>Save as… and save it to your project folder to replace the previous one.

Note: I didn’t fix the incorrect tag usage in that file.

By the way, I’m still looking at your SketchUp file. I see a number of other things that could be done more efficiently. One of them is to avoid the unneeded nesting in components. There’s really no benefit to doing that here. Example:

Yes. I do. We could work out a time. Send me a PM.

Great, just messaged you =)